classification
Title: py_compile.py quiet undefined in main function
Type: crash Stage: resolved
Components: Library (Lib) Versions: Python 3.8
process
Status: closed Resolution: duplicate
Dependencies: Superseder: bad input crashes py_compile library
View: 38731
Assigned To: Nosy List: Georgy Kibardin, Vikash Balasubramanian, xtreak
Priority: normal Keywords:

Created on 2020-03-22 04:34 by Vikash Balasubramanian, last changed 2020-03-31 09:06 by xtreak. This issue is now closed.

Messages (8)
msg364780 - (view) Author: Vikash Balasubramanian (Vikash Balasubramanian) Date: 2020-03-22 04:34
I just had a random crash while using the autocomplete feature of Emacs.

The error message was basically thrown by py_compile.py:213

quiet is undefined. I tracked down the code and sure enough, there is a comparison

if quiet < 2:
    ....

Please confirm this.
msg364781 - (view) Author: Karthikeyan Singaravelan (xtreak) * (Python committer) Date: 2020-03-22 04:42
This is a duplicate of https://bugs.python.org/issue38731
msg364800 - (view) Author: Karthikeyan Singaravelan (xtreak) * (Python committer) Date: 2020-03-22 12:15
Closing this as duplicate. Feel free to reopen if it's a mistake. Thanks.
msg365337 - (view) Author: Georgy Kibardin (Georgy Kibardin) Date: 2020-03-30 18:48
This is not a duplicate of https://bugs.python.org/issue38731. quiet is is still undefined in main()
msg365338 - (view) Author: Georgy Kibardin (Georgy Kibardin) Date: 2020-03-30 18:49
Please, reopen.
msg365366 - (view) Author: Karthikeyan Singaravelan (xtreak) * (Python committer) Date: 2020-03-31 04:55
I feel it's the same. It also reports about the undeclared variable just being found by bad file used with py_compile. It was also reported at https://bugs.python.org/issue39743. Can you please explain why this is not a duplicate?
msg365368 - (view) Author: Georgy Kibardin (Georgy Kibardin) Date: 2020-03-31 09:01
https://bugs.python.org/issue39743 is closed as duplicate of https://bugs.python.org/issue38731. 

https://bugs.python.org/issue38731 fixes undeclared variable "quiet" in function compile().
At the same time variable "quiet" is used in function main() where it is still undeclared and 38731 doesn't fix this problem - it is still there, in python 3.8.2.
msg365370 - (view) Author: Karthikeyan Singaravelan (xtreak) * (Python committer) Date: 2020-03-31 09:06
There is PR https://github.com/python/cpython/pull/17134 which is not merged to fix the exception so this is not fixed for 3.8.2. Once the fix is applied and released you can test the same
History
Date User Action Args
2020-03-31 09:06:40xtreaksetmessages: + msg365370
2020-03-31 09:01:09Georgy Kibardinsetmessages: + msg365368
2020-03-31 04:55:47xtreaksetmessages: + msg365366
2020-03-30 18:49:22Georgy Kibardinsetmessages: + msg365338
2020-03-30 18:48:21Georgy Kibardinsetnosy: + Georgy Kibardin
messages: + msg365337
2020-03-22 12:15:50xtreaksetstatus: open -> closed
superseder: bad input crashes py_compile library
messages: + msg364800

resolution: duplicate
stage: resolved
2020-03-22 04:42:10xtreaksetnosy: + xtreak
messages: + msg364781
2020-03-22 04:34:22Vikash Balasubramaniancreate