classification
Title: test_ssl and test_urllib2_localnet failing with new OpenSSL
Type: behavior Stage: resolved
Components: SSL, Tests Versions: Python 3.9, Python 3.8, Python 3.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: test_ssl fails with OpenSSL 1.1.1e
View: 40018
Assigned To: christian.heimes Nosy List: christian.heimes, mscastanho, vstinner
Priority: normal Keywords:

Created on 2020-02-28 20:02 by mscastanho, last changed 2020-03-23 14:52 by vstinner. This issue is now closed.

Files
File name Uploaded Description Edit
test-output.txt mscastanho, 2020-02-28 20:02
Messages (2)
msg362915 - (view) Author: Matheus Castanho (mscastanho) Date: 2020-02-28 20:02
test_ssl and test_urllib2_localnet are failing when Python is built against top-of-tree OpenSSL. I'm attaching the output of: `regrtest.py test_ssl test_urllib2_localnet -W`

The output is from a powerpc64le machine with Python 3.8.2+ (1bbb81b251bc) and OpenSSL master (db943f43a60d1b).

A git bisect showed the problems started with the following OpenSSL commit:

commit db943f43a60d1b5b1277e4b5317e8f288e7a0a3a
Author: Matt Caswell <matt@openssl.org>
Date:   Fri Jan 17 17:39:19 2020 +0000

    Detect EOF while reading in libssl
    
    If we hit an EOF while reading in libssl then we will report an error
    back to the application (SSL_ERROR_SYSCALL) but errno will be 0. We add
    an error to the stack (which means we instead return SSL_ERROR_SSL) and
    therefore give a hint as to what went wrong.
    
    Contains a partial fix for #10880
    
    Reviewed-by: Tomas Mraz <tmraz@fedoraproject.org>
    Reviewed-by: Dmitry Belyavskiy <beldmit@gmail.com>
    (Merged from https://github.com/openssl/openssl/pull/10882)

This also looks similar to: https://bugs.python.org/issue28689
msg364853 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2020-03-23 14:52
Duplicate of bpo-40018.
History
Date User Action Args
2020-03-23 14:52:51vstinnersetstatus: open -> closed

superseder: test_ssl fails with OpenSSL 1.1.1e

nosy: + vstinner
messages: + msg364853
resolution: duplicate
stage: resolved
2020-02-28 20:02:38mscastanhocreate