classification
Title: Event sequence "KeyRelease-Shift_R" not being fired
Type: behavior Stage: resolved
Components: Tkinter Versions: Python 3.8
process
Status: closed Resolution: third party
Dependencies: Superseder:
Assigned To: Nosy List: Devin Morgan, cheryl.sabella, epaine
Priority: normal Keywords:

Created on 2020-02-26 06:40 by Devin Morgan, last changed 2020-06-14 16:37 by cheryl.sabella. This issue is now closed.

Files
File name Uploaded Description Edit
Py-Pong.py Devin Morgan, 2020-02-26 06:40
Messages (3)
msg362682 - (view) Author: Devin Morgan (Devin Morgan) Date: 2020-02-26 06:40
Trying to create a remake of Pong and am trying to use Right Control and Right Shift to move the right paddle up and down, moving the paddle down works fine but gets stuck in the move up state, despite my efforts root out logic errors through reviewing and debugging my code and the logic is correct.
msg371508 - (view) Author: E. Paine (epaine) * Date: 2020-06-14 16:17
This is strange, as the release of the right-shift key triggers the binding for the left-shift release. This issue, however, is not a tkinter issue (which just passes the calls onto Tcl/Tk), as running the following in 'wish' prints "R shift down <newline> L shift up":

bind . <Shift_L> {puts {L shift down}}
bind . <KeyRelease-Shift_L> {puts {L shift up}}
bind . <Shift_R> {puts {R shift down}}
bind . <KeyRelease-Shift_R> {puts {R shift up}}

You can take this issue up with the Tcl team if you want (https://core.tcl-lang.org/index.html), however, I ask that you close this issue as third party.
msg371509 - (view) Author: Cheryl Sabella (cheryl.sabella) * (Python committer) Date: 2020-06-14 16:37
@Devin Morgan, thank you for the report and @epaine, thank you for researching the cause.  I'll close this as third party.
History
Date User Action Args
2020-06-14 16:37:01cheryl.sabellasetstatus: open -> closed

nosy: + cheryl.sabella
messages: + msg371509

resolution: third party
stage: resolved
2020-06-14 16:17:20epainesetnosy: + epaine
messages: + msg371508
2020-02-26 06:40:12Devin Morgancreate