classification
Title: mod operation with large number is not correct.
Type: behavior Stage: resolved
Components: Windows Versions: Python 3.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: paul.moore, steve.dower, steven.daprano, tim.golden, wjzbf, zach.ware
Priority: normal Keywords:

Created on 2020-02-24 09:28 by wjzbf, last changed 2020-02-24 09:42 by steven.daprano. This issue is now closed.

Messages (2)
msg362574 - (view) Author: (wjzbf) Date: 2020-02-24 09:28
hello python,

  when i calculate:

151476660579404160000-151476660579404160000//1000000007 * (1e9+7)

  it returns 

67534848.0

  when i calculate 

151476660579404160000 % (1e9+7)

  it returns 

67536199.0

  the two values are not equal.
  how to explain it?

thanks
zbf
msg362575 - (view) Author: Steven D'Aprano (steven.daprano) * (Python committer) Date: 2020-02-24 09:42
This is a floating point issue, not a bug. Floats inherently only have a limited precision available, so they are not always the exact number you think they are.

Using 1e9 forces the result to be a float, which introduces rounding errors into the calculation. If you use an exact integer, the calculation is exact:


py> 151476660579404160000-151476660579404160000//1000000007 * (10**9+7)
67543367
py> 151476660579404160000 % (10**9+7)
67543367


*This is not a Python bug* this is an inherent limitation of floating point numbers and the same issues will occur in any language that uses floats.

https://docs.python.org/3/faq/design.html#why-am-i-getting-strange-results-with-simple-arithmetic-operations
History
Date User Action Args
2020-02-24 09:42:47steven.dapranosetstatus: open -> closed

nosy: + steven.daprano
messages: + msg362575

resolution: not a bug
stage: resolved
2020-02-24 09:28:03wjzbfcreate