classification
Title: Tix Tree widget no longer instantiable.
Type: Stage:
Components: Tkinter Versions: Python 2.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Python 2.6rc2: Tix ComboBox error
View: 3872
Assigned To: Nosy List: amaury.forgeotdarc, ronLongo
Priority: normal Keywords:

Created on 2008-09-26 00:52 by ronLongo, last changed 2008-09-26 07:01 by amaury.forgeotdarc. This issue is now closed.

Messages (2)
msg73830 - (view) Author: Ron Longo (ronLongo) Date: 2008-09-26 00:52
The following code works in Python 2.5 but not in Python 2.6:  I've 
tested on Windows XP and Windows Vista.

from Tix import *
root = Tk()
t = Tree( root )

In Python 2.6 the following exception is thrown while trying to execute 
the last statement above:

Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "C:\Python26\lib\lib-tk\Tix.py", line 1519, in __init__
    ['options'], cnf, kw)
  File "C:\Python26\lib\lib-tk\Tix.py", line 307, in __init__
    self.tk.call(widgetName, self._w, *extra)
_tkinter.TclError: unknown color name "{#c3c3c3}"
msg73835 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2008-09-26 07:01
Duplicate of issue3872. Tix seems really broken with tcl8.5...
History
Date User Action Args
2008-09-26 07:01:10amaury.forgeotdarcsetstatus: open -> closed
resolution: duplicate
superseder: Python 2.6rc2: Tix ComboBox error
messages: + msg73835
nosy: + amaury.forgeotdarc
2008-09-26 00:52:31ronLongocreate