classification
Title: logger.exception with default message
Type: enhancement Stage: resolved
Components: Versions: Python 3.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Denis Vieira, vinay.sajip
Priority: normal Keywords:

Created on 2020-02-12 17:56 by Denis Vieira, last changed 2020-02-14 22:10 by vinay.sajip. This issue is now closed.

Messages (2)
msg361908 - (view) Author: Denis Vieira (Denis Vieira) Date: 2020-02-12 17:56
On my Python projects i like to use the logger.exception() method without any other message. 

I'm forced to send an empty string on every call.
logger.exception('')

It would be nice the exception method have the expected parameter "msg" with an default value ('').
msg362001 - (view) Author: Vinay Sajip (vinay.sajip) * (Python committer) Date: 2020-02-14 22:10
Sorry, I don't think this change is a good idea. It's not clear what the value is in logging exceptions with no message.
History
Date User Action Args
2020-02-14 22:10:16vinay.sajipsetstatus: open -> closed
resolution: not a bug
messages: + msg362001

stage: resolved
2020-02-12 18:42:16xtreaksetnosy: + vinay.sajip
2020-02-12 17:56:31Denis Vieiracreate