classification
Title: Arrows key do not browse in the IDLE
Type: behavior Stage: test needed
Components: Versions: Python 3.0
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: ajaksu2, gpolo, italian-boy
Priority: normal Keywords:

Created on 2008-09-25 13:06 by italian-boy, last changed 2009-08-04 14:39 by gpolo. This issue is now closed.

Files
File name Uploaded Description Edit
maketestpython30_log.txt italian-boy, 2008-09-25 13:06 make test log (python3.0rc1)
Messages (3)
msg73788 - (view) Author: Richard (italian-boy) Date: 2008-09-25 13:06
I open python3.0 (rc1) IDLE from command line and it works fine, but
when i press the arrows key they writes: ^[[A ^[[B ^[[C ^[[D
also pagUP and pagDOWN writes: ^[[5~ ^[[6~
so I'm not able to browse the history and the all things with arrows key.

More Info:

my OS is Ubuntu 8.04 upgrade from 7.10

It's the first time that I have an issue with keyboard

I have look for my international settings of keyboard but I don't note
nothing of relevant. (my country is Italy-Europe)

I have installed as main python 2.5 with I have no problem (works perfect)

I made a standard alt-installation
./configure
make
make test   # 1error with urllib2 and some skip (see attach txt)
sudo make altinstall

I have no other kind of problems with python3.0rc1

Is there someone has an idea??

 -- Richard (excuse my English)
msg86617 - (view) Author: Daniel Diniz (ajaksu2) (Python triager) Date: 2009-04-26 22:15
Richard: what do the same keys do in the command line interpreter?
msg91257 - (view) Author: Guilherme Polo (gpolo) * (Python committer) Date: 2009-08-04 14:39
Richard, IDLE doesn't support browsing the history of the commands
entered (see issue2704), so I believe this is not related to IDLE and I
believe you meant to talk about the standard python shell.

Since you have compiled python yourself it is possible that you didn't
have the development package of readline installed (it is
libreadline5-dev on ubuntu), which would cause the problem you described
when using the standard python shell.
History
Date User Action Args
2009-08-04 14:39:50gpolosetstatus: open -> closed

messages: + msg91257
resolution: not a bug
components: - IDLE
2009-04-26 22:15:21ajaksu2setpriority: normal

nosy: + ajaksu2, gpolo
messages: + msg86617

stage: test needed
2008-09-25 13:06:50italian-boycreate