classification
Title: sorting the String
Type: Stage: resolved
Components: Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Shani M, ronaldoussoren
Priority: normal Keywords:

Created on 2020-02-10 08:41 by Shani M, last changed 2020-02-10 15:12 by zach.ware. This issue is now closed.

Files
File name Uploaded Description Edit
Screenshot from 2020-02-10 14-08-52.png Shani M, 2020-02-10 08:41
Messages (2)
msg361675 - (view) Author: Shani M (Shani M) Date: 2020-02-10 08:41
It showing the wrong string order. 'sss' is to be appear at 3rd place but it comes at last place. 'qwe' is to appear at last place but it comes at 3rd place.
msg361680 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2020-02-10 11:29
From the screenshot:

>>> b = ['sss', 'ase', 'klm', 'qwe']
>>> print sorted(b)
['ase', 'klm', 'qwe', 'sss']

This is the correct result, the output list is alphabetically sorted.
History
Date User Action Args
2020-02-10 15:12:57zach.waresetstatus: pending -> closed
stage: resolved
2020-02-10 11:29:02ronaldoussorensetstatus: open -> pending

nosy: + ronaldoussoren
messages: + msg361680

resolution: not a bug
2020-02-10 08:41:14Shani Mcreate