classification
Title: IDLE won't start in 3.0rc1 "Subprocess didn't make connection...."
Type: crash Stage:
Components: IDLE Versions: Python 3.0
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: amaury.forgeotdarc, jmfauth, rbtyod
Priority: normal Keywords:

Created on 2008-09-23 02:55 by rbtyod, last changed 2008-09-25 19:20 by amaury.forgeotdarc. This issue is now closed.

Messages (7)
msg73613 - (view) Author: Robert Yodlowski (rbtyod) Date: 2008-09-23 02:55
I installed 3.0rc1 on a Win XP 2.4Gzh system with all current updates
with no problems. Cmd line Python and docs work fine. 

Tried to start IDLE but got error message: "IDLE's subprocess didn't
make connection. Either IDLE can't start subprocess or personal firewall
is blocking." 

I turned off my firewall but got the same error message. IDLE works fine
in Python 2.5 and 2.6 on this same machine. Tried change to
idlelib\run.py suggested in bug report #3905 but it had no effect.

...Bob
msg73620 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2008-09-23 08:19
It is probably already corrected in svn.

Can you please try from a command prompt:

> cd <path_to_python3.0rc1>
> python Lib/idlelib/idle.py

Does this display some error message?
msg73622 - (view) Author: jmf (jmfauth) Date: 2008-09-23 09:23
I think the problem is fixed.
See issue 3905.
msg73623 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2008-09-23 09:31
But #3905 is not yet fixed, furthermore the OP already tried the
correction suggested there.
msg73751 - (view) Author: Robert Yodlowski (rbtyod) Date: 2008-09-24 19:42
Amaury, I did as you suggested - running idle.py directly both from a
command line and by clicking on it and the results were the same. Each
time, I got the same error message window as before. In addition,
several seconds before the error window came up I got the following
traceback in the command window:

C:\Python30>python Lib/idlelib/idle.py
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "C:\Python30\lib\idlelib\run.py", line 76, in main
    sockthread.set_daemon(True)
AttributeError: 'Thread' object has no attribute 'set_daemon'

I hope this helps.
...Bob
msg73771 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2008-09-25 07:08
Did you *really* follow the suggested change proposed in #3905 ?
http://bugs.python.org/msg73496
msg73806 - (view) Author: Robert Yodlowski (rbtyod) Date: 2008-09-25 17:53
Amaury, my stupid! I must have forgotten to delete the run.pyc file
before trying out the modified run.py as suggested in #3905 . It all
works now and IDLE starts up just fine.

Sorry and, thanks for the help.

...Bob
History
Date User Action Args
2008-09-25 19:20:28amaury.forgeotdarcsetstatus: open -> closed
resolution: not a bug
2008-09-25 17:53:04rbtyodsetmessages: + msg73806
2008-09-25 07:08:38amaury.forgeotdarcsetmessages: + msg73771
2008-09-24 19:42:17rbtyodsetmessages: + msg73751
2008-09-23 09:31:46amaury.forgeotdarcsetmessages: + msg73623
2008-09-23 09:23:32jmfauthsetnosy: + jmfauth
messages: + msg73622
2008-09-23 08:19:46amaury.forgeotdarcsetnosy: + amaury.forgeotdarc
messages: + msg73620
2008-09-23 02:55:46rbtyodcreate