classification
Title: AMD64 Fedora Rawhide Clang 3.x: C compiler cannot create executables
Type: Stage: resolved
Components: Tests Versions: Python 3.9
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: vstinner
Priority: normal Keywords: buildbot

Created on 2020-01-20 17:14 by vstinner, last changed 2020-01-24 10:27 by vstinner. This issue is now closed.

Messages (2)
msg360324 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2020-01-20 17:14
"AMD64 Fedora Rawhide Clang 3.x" buildbot worker is currently broken:
https://buildbot.python.org/all/#/builders/169/builds/168

clang cannot build (statically linked) binary using UBSan:

$ ./configure --prefix '$(PWD)/target' CC=clang LD=clang CFLAGS=-fsanitize=undefined LDFLAGS=-fsanitize=undefined
...
checking for gcc... clang
checking whether the C compiler works... no
configure: error: in `/home/buildbot/buildarea/3.x.cstratak-fedora-rawhide-x86_64.clang-ubsan/build':
configure: error: C compiler cannot create executables
See `config.log' for more details

I reproduced the issue on the worker. The issue comes from a version conflict between clang and compiler-rt packages:

compiler-rt-9.0.0-1.fc32.x86_64 uses /usr/lib64/clang/9.0.0/...

vs

clang-9.0.1-2.fc32.x86_64 uses /usr/lib64/clang/9.0.1/...

Charalampos created https://src.fedoraproject.org/rpms/compiler-rt/pull-request/10 to propose to update compiler-rt.
msg360604 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2020-01-24 10:27
Charalampos downgraded clang to 10.0.0 to workaround the issue. The buildbot worker compiles the code succesfully again:
https://buildbot.python.org/all/#/builders/169

I close the issue. The issue is now tracked in Fedora Rawhide anyway:
https://src.fedoraproject.org/rpms/compiler-rt/pull-request/10
History
Date User Action Args
2020-01-24 10:27:17vstinnersetstatus: open -> closed
resolution: fixed
messages: + msg360604

stage: resolved
2020-01-20 17:14:25vstinnercreate