classification
Title: 3.0rc1 missing tk lib in sys.path?
Type: behavior Stage:
Components: Library (Lib) Versions: Python 3.0
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: jmfauth, loewis
Priority: normal Keywords:

Created on 2008-09-21 10:09 by jmfauth, last changed 2008-09-21 17:24 by loewis. This issue is now closed.

Messages (2)
msg73508 - (view) Author: jmf (jmfauth) Date: 2008-09-21 10:09
3.0rc1: When toying and attempting to import the scrolledtext module, I
noticed the tkinter library path is no more by default included in the
sys.path.

Unfortunate omission or new Python 3.0 design?

C:\Python30>python
Python 3.0rc1 (r30rc1:66507, Sep 18 2008, 14:47:08) [MSC v.1500 32 bit
(Intel)]
on win32
Type "help", "copyright", "credits" or "license" for more information.
>>> import sys
>>> for e in sys.path: print(e)
...

C:\Python30\python30.zip
C:\Python30\DLLs
C:\Python30\lib
C:\Python30\lib\plat-win
C:\Python30
C:\Python30\lib\site-packages
>>>


C:\Python26>python
Python 2.6rc2 (r26rc2:66507, Sep 18 2008, 14:27:33) [MSC v.1500 32 bit
(Intel)]
on win32
Type "help", "copyright", "credits" or "license" for more information.
>>> import sys
>>> for e in sys.path: print e
...

C:\Python26\python26.zip
C:\Python26\DLLs
C:\Python26\lib
C:\Python26\lib\plat-win
C:\Python26\lib\lib-tk <<<<<<<<<<<<<<<<<<<<<<<<<
C:\Python26
C:\Python26\lib\site-packages
>>>
msg73516 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2008-09-21 17:24
This is intentional. tkinter now lives directly in the lib directory
(and is a package).
History
Date User Action Args
2008-09-21 17:24:11loewissetstatus: open -> closed
resolution: not a bug
messages: + msg73516
nosy: + loewis
2008-09-21 10:09:41jmfauthcreate