classification
Title: Add support for HTTP Only flag in MozillaCookieJar
Type: enhancement Stage: resolved
Components: Library (Lib) Versions: Python 3.10
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: orsenthil Nosy List: Jacob Taylor, dlenski, orsenthil
Priority: normal Keywords: patch

Created on 2019-12-05 05:13 by Jacob Taylor, last changed 2020-11-15 20:38 by dlenski. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 17471 merged Jacob Taylor, 2019-12-05 05:14
PR 22798 dlenski, 2020-11-15 20:38
Messages (3)
msg357837 - (view) Author: Jacob Taylor (Jacob Taylor) * Date: 2019-12-05 05:13
This PR adds support for the HttpOnly flag as encoded in CURL cookiejars.

This PR was mainly designed to allow the MozillaCookieJar to parse in the cookies, as previously they were considered comments and ignored. 

As HttpOnly is considered a non-standard attribute, the nonstandard attribute dict was considered the most appropriate place to persist this information.
msg379487 - (view) Author: Senthil Kumaran (orsenthil) * (Python committer) Date: 2020-10-23 22:49
New changeset 16ee68da6e12bb2d79751b32cc37523fe4f4bb48 by Jacob Neil Taylor in branch 'master':
bpo-38976: Add support for HTTP Only flag in MozillaCookieJar (#17471)
https://github.com/python/cpython/commit/16ee68da6e12bb2d79751b32cc37523fe4f4bb48
msg381033 - (view) Author: Daniel Lenski (dlenski) * Date: 2020-11-15 20:37
This issue is essentially a duplicate of the very-longstanding #2190.

My PR (https://github.com/python/cpython/pull/22798) was submitted before this one, but this one was accepted and merged first.
History
Date User Action Args
2020-11-15 20:38:00dlenskisetpull_requests: + pull_request22196
2020-11-15 20:37:05dlenskisetnosy: + dlenski
messages: + msg381033
2020-10-23 22:49:45orsenthilsetstatus: open -> closed
stage: patch review -> resolved
resolution: fixed
versions: + Python 3.10, - Python 3.9
2020-10-23 22:49:03orsenthilsetmessages: + msg379487
2020-03-31 02:59:08orsenthilsetassignee: orsenthil

nosy: + orsenthil
2019-12-05 05:14:26Jacob Taylorsetkeywords: + patch
stage: patch review
pull_requests: + pull_request16951
2019-12-05 05:13:43Jacob Taylorcreate