classification
Title: test_ssl fails in all Fedora buildbots
Type: Stage: resolved
Components: Tests Versions: Python 3.9, Python 3.8
process
Status: closed Resolution: duplicate
Dependencies: Superseder: test_ssl: test_min_max_version() fails on FreeBSD and Fedora
View: 38815
Assigned To: Nosy List: pablogsal, vstinner
Priority: normal Keywords:

Created on 2019-12-02 13:38 by pablogsal, last changed 2019-12-02 13:41 by vstinner. This issue is now closed.

Messages (2)
msg357708 - (view) Author: Pablo Galindo Salgado (pablogsal) * (Python committer) Date: 2019-12-02 13:38
This issue is probably duplicate of some other, but I decided to make one new one due to the fact that this affect all Fedora build bots.


test test_ssl failed
test_timeout_connect_ex (test.test_ssl.NetworkedTests) ... ok
======================================================================
FAIL: test_min_max_version (test.test_ssl.ContextTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/buildbot/buildarea/3.8.cstratak-fedora-rawhide-x86_64.lto-pgo/build/Lib/test/test_ssl.py", line 1207, in test_min_max_version
    self.assertEqual(
AssertionError: <TLSVersion.TLSv1_3: 772> != <TLSVersion.MAXIMUM_SUPPORTED: -1>
----------------------------------------------------------------------
Ran 161 tests in 2.681s
FAILED (failures=1, skipped=11)
1 test failed again:
    test_ssl

Example failure:

https://buildbot.python.org/all/#/builders/222
msg357709 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2019-12-02 13:41
I suggest to reuse bpo-38815.
History
Date User Action Args
2019-12-02 13:41:41vstinnersetstatus: open -> closed
superseder: test_ssl: test_min_max_version() fails on FreeBSD and Fedora
messages: + msg357709

resolution: duplicate
stage: resolved
2019-12-02 13:38:37pablogsalcreate