classification
Title: Modify PyInterpreterState.eval_frame to pass tstate (PyThreadState)
Type: Stage: resolved
Components: Interpreter Core Versions: Python 3.9
process
Status: closed Resolution: duplicate
Dependencies: Superseder: PEP 523: Add private _PyInterpreterState_SetEvalFrameFunc() function to the C API (Python 3.8 regression)
View: 38500
Assigned To: Nosy List: brett.cannon, vstinner
Priority: normal Keywords: patch

Created on 2019-11-16 00:11 by vstinner, last changed 2020-03-10 17:34 by vstinner. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 17187 closed vstinner, 2019-11-16 00:18
PR 17352 closed vstinner, 2019-11-22 18:06
PR 17340 vstinner, 2020-03-10 17:34
Messages (3)
msg356736 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2019-11-16 00:11
Follow-up of bpo-36710 and bpo-38644: I would like to pass explicitly tstate (PyThreadState) to internal C functions.

The problem is that PyInterpreterState.eval_frame function has no tstate parameter. I propose attached PR to add a tstate parameter. It's a backward incompatible change. The "eval_frame" field comes from the PEP 523.

See also bpo-38500 "Provide a way to get/set PyInterpreterState.frame_eval without needing to access interpreter internals".
msg356894 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2019-11-18 18:23
I think bpo-38500 needs to get resolved first before this as that will affect whether this is acceptable or not as an API-breaking change.
msg363832 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2020-03-10 17:32
I mark this issue as a duplicate of bpo-38500.
History
Date User Action Args
2020-03-10 17:34:08vstinnersetpull_requests: + pull_request18260
2020-03-10 17:32:12vstinnersetstatus: open -> closed
superseder: PEP 523: Add private _PyInterpreterState_SetEvalFrameFunc() function to the C API (Python 3.8 regression)
messages: + msg363832

resolution: duplicate
stage: patch review -> resolved
2019-11-22 18:06:23vstinnersetpull_requests: + pull_request16837
2019-11-18 18:23:14brett.cannonsetmessages: + msg356894
2019-11-16 00:18:25vstinnersetkeywords: + patch
stage: patch review
pull_requests: + pull_request16694
2019-11-16 00:11:33vstinnercreate