classification
Title: 2.6 regression in urllib.getproxies_environment
Type: behavior Stage:
Components: Versions: Python 2.6
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: georg.brandl Nosy List: benjamin.peterson, georg.brandl, matejcik, vila
Priority: release blocker Keywords: needs review, patch

Created on 2008-09-16 12:37 by vila, last changed 2008-09-21 21:28 by benjamin.peterson. This issue is now closed.

Files
File name Uploaded Description Edit
bug-no-proxy.patch vila, 2008-09-16 12:37 Revert incompatible and apparently gratuitous filtering of 'no_proxy' variables
issue3879.patch vila, 2008-09-18 10:44 patch with test
Messages (7)
msg73298 - (view) Author: (vila) Date: 2008-09-16 12:37
With or without this patch, running:

./python.exe -E -tt ./Lib/test/regrtest.py -l -u network 
test_urllib2net test_urllibnet test_socketserver test_SimpleHTTPServer 

succeeds

Since this is a regression from 2.5, can this patch be applied to 2.6
final ?
msg73307 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-09-16 20:32
It would be nice to have a test for the patch.
msg73369 - (view) Author: (vila) Date: 2008-09-18 10:44
Here you are
msg73410 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-09-18 23:17
Georg, you applied the offending patch. Can you comment?
msg73499 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2008-09-21 07:48
I think the patch is okay; I guess you're processing the result of
getproxies() yourself and relying on "no" being a key?
msg73505 - (view) Author: (vila) Date: 2008-09-21 08:40
Georg Brandl:
> I guess you're processing the result of
> getproxies() yourself and relying on "no" being a key?

Indeed. Thanks for approving this.
msg73532 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-09-21 21:28
Fixed in r66544.
History
Date User Action Args
2008-09-21 21:28:18benjamin.petersonsetstatus: open -> closed
resolution: accepted -> fixed
messages: + msg73532
2008-09-21 08:40:42vilasetmessages: + msg73505
2008-09-21 07:48:26georg.brandlsetresolution: accepted
messages: + msg73499
2008-09-18 23:17:58benjamin.petersonsetassignee: georg.brandl
messages: + msg73410
nosy: + georg.brandl
2008-09-18 11:51:27benjamin.petersonsetpriority: release blocker
keywords: + needs review
2008-09-18 10:44:42vilasetfiles: + issue3879.patch
messages: + msg73369
2008-09-16 20:32:47benjamin.petersonsetnosy: + benjamin.peterson
messages: + msg73307
2008-09-16 12:55:27matejciksetnosy: + matejcik
2008-09-16 12:37:01vilacreate