classification
Title: ImportError: No module named test.test_support
Type: crash Stage:
Components: Windows Versions: Python 2.6
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: amaury.forgeotdarc, wplappert
Priority: normal Keywords:

Created on 2008-09-13 08:16 by wplappert, last changed 2008-09-13 17:16 by benjamin.peterson. This issue is now closed.

Messages (4)
msg73169 - (view) Author: Winfried Plappert (wplappert) Date: 2008-09-13 08:16
The following 2 line program fails under Python 2.6rc1: 
Python 2.6b3 (r26b3:66303, Sep  8 2008, 13:45:13) [MSC v.1500 32 bit
(Intel)] on win32

as downloaded today (2008-09-13):

#---- start program ---
import urllib
fh = urllib.urlopen('http://bugs.python.org/')
#---- end program ---

with the messages:
Traceback (most recent call last):
  File "bug.py", line 2, in <module>
    fh = urllib.urlopen('http://bugs.python.org/')
  File "d:\Python26\lib\urllib.py", line 87, in urlopen
    return opener.open(url)
  File "d:\Python26\lib\urllib.py", line 203, in open
    return getattr(self, name)(url)
  File "d:\Python26\lib\urllib.py", line 285, in open_http
    import httplib
  File "d:\Python26\lib\httplib.py", line 72, in <module>
    from test.test_support import catch_warning
ImportError: No module named test.test_support

The program works fine on Python 2.5
msg73171 - (view) Author: Winfried Plappert (wplappert) Date: 2008-09-13 09:16
OK, by now I know exactly what the problem is: The Windows installer
allows you the option of DESELECTING the "Test Suite". Initially I
deselected the Test Suite because I thought I do not need it. But this
is wrong. urllib loads test.test_support. 

In my opinion you must not be able to deselect a feature if this feature
is needed for the proper running of Python.

PS.: Forget all the bits about "Python 2.6b3 (r26b3:66303, Sep  8 2008,
13:45:13) [MSC v.1500 32 bit (Intel)] on win32": I just was too fast. I
have verified the bug now with proper 2.6rc1: Python 2.6rc1
(r26rc1:66438, Sep 13 2008, 09:20:38) [MSC v.1500 32 bit (Intel)].

Thanks a lot for the wonderful programming language Python!!
msg73173 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2008-09-13 09:53
I just installed python 2.6rc1, and I don't get the error at all.
are you sure that you did not install a 2.6b3 afterwards?

The content of your file d:\Python26\lib\httplib.py does not match with
mine, suggest a version mismatch.
msg73193 - (view) Author: Winfried Plappert (wplappert) Date: 2008-09-13 17:14
Please close this issue. Between 2.6b3 and 2.6rc1 Lib/httplib.py has
been changed. Sorry about the confusion!
History
Date User Action Args
2008-09-13 17:16:21benjamin.petersonsetstatus: open -> closed
resolution: out of date
2008-09-13 17:14:52wplappertsetmessages: + msg73193
2008-09-13 09:53:40amaury.forgeotdarcsetnosy: + amaury.forgeotdarc
messages: + msg73173
2008-09-13 09:16:31wplappertsetmessages: + msg73171
components: + Windows, - Library (Lib)
2008-09-13 08:16:51wplappertcreate