classification
Title: Typo (nam ing) in import system docs
Type: Stage: resolved
Components: Documentation Versions: Python 3.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: docs@python, eric.smith, roysmith
Priority: normal Keywords:

Created on 2019-10-13 13:31 by roysmith, last changed 2019-11-27 19:53 by roysmith. This issue is now closed.

Files
File name Uploaded Description Edit
Screen Shot 2019-10-13 at 10.12.15 AM.jpg roysmith, 2019-10-13 14:27
Messages (4)
msg354581 - (view) Author: Roy Smith (roysmith) Date: 2019-10-13 13:31
In https://docs.python.org/3.5/reference/import.html#importsystem, section "5.2 Packages", second sentence, the word "naming" is broken across two lines.

In 3.7.5rc1 as well.  Didn't check any others.
msg354583 - (view) Author: Eric V. Smith (eric.smith) * (Python committer) Date: 2019-10-13 14:04
I'm not seeing this in either the master or 3.5 branches. Perhaps this is being done locally by your browser?

Unfortunately I can't find a way for github to link to a specific line in a .rst file, but when I look at the source code and https://github.com/python/cpython/blob/3.5/Doc/reference/import.rst, I don't see any line breaks.
msg354585 - (view) Author: Roy Smith (roysmith) Date: 2019-10-13 14:27
Yeah, that's weird.  Looks like this may be a Chrome bug.  I'm seeing it in Chrome (Version 77.0.3865.90 (Official Build) (64-bit)), but not Safari.  This is on MacOS (High Sierra).


In the attached screenshot, I narrowed the window a bit.  In the second paragraph, it's mis-broken "modules" and "contain", but hyphenated some other line breaks.  If I diddle with the CSS and disable "hyphens: auto", it stops breaking words completely (which is probably better than breaking them wrong).

I guess close this and I'll open a bug against Chrome.
msg357580 - (view) Author: Roy Smith (roysmith) Date: 2019-11-27 19:53
Just for the archives:

https://bugs.chromium.org/p/chromium/issues/detail?id=1022011
History
Date User Action Args
2019-11-27 19:53:32roysmithsetmessages: + msg357580
2019-10-13 16:11:27eric.smithsetstatus: open -> closed
resolution: not a bug
stage: resolved
2019-10-13 14:27:26roysmithsetfiles: + Screen Shot 2019-10-13 at 10.12.15 AM.jpg

messages: + msg354585
2019-10-13 14:04:29eric.smithsetnosy: + eric.smith
messages: + msg354583
2019-10-13 13:31:35roysmithcreate