classification
Title: 3.8 Release Notes: document asyncio exception changes
Type: Stage: resolved
Components: Documentation Versions: Python 3.8
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: yselivanov Nosy List: akuchling, asvetlov, docs@python, rhettinger, srittau, yselivanov
Priority: normal Keywords:

Created on 2019-10-13 12:20 by srittau, last changed 2021-06-14 12:16 by srittau. This issue is now closed.

Messages (6)
msg354577 - (view) Author: Sebastian Rittau (srittau) * Date: 2019-10-13 12:20
In Python 3.8 asyncio exceptions were consolidated into the new module "asyncio.exceptions". Previously they were spread out over several modules. While the documentation always mandated to import the exceptions from top-level "asyncio", code that incorrectly imported directly from the submodules will break.
msg354614 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2019-10-14 03:57
Yuri, would you propose an entry for this?
msg355142 - (view) Author: Sebastian Rittau (srittau) * Date: 2019-10-22 17:16
Also it seems there are various new arguments and methods in asyncio that are not in the release notes. (Via https://github.com/python/typeshed/issues/2313).
msg355144 - (view) Author: Andrew Svetlov (asvetlov) * (Python committer) Date: 2019-10-22 18:11
> code that incorrectly imported directly from the submodules will break

That's true. Please note: incorrect code will break. The correct code keeps working.

I'm personally not sure if we need to reflect *private* API change in Release Notes.

Another question is: should Release Notes reflect all API updates? We strictly control `versionadded` and `versionchanged` usage in asyncio docs but don't do it for whatsnew files.
msg355206 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2019-10-23 03:42
> I'm personally not sure if we need to reflect *private*
> API change in Release Notes

The whatsnew 3.8 document is for significant changes to public APIs.  The changelog (built from the news entries) has much more extensive detail.  The main docs are where we put versionadded/versionchanged so that there is a source for knowing which features run in which versions of Python.
msg395791 - (view) Author: Sebastian Rittau (srittau) * Date: 2021-06-14 12:16
Closing per the comments by Andrew and Raymond and the fact that 3.8 has been released for quite some while now.
History
Date User Action Args
2021-06-14 12:16:23srittausetresolution: not a bug
2021-06-14 12:16:18srittausetstatus: open -> closed

messages: + msg395791
stage: resolved
2019-10-23 03:42:54rhettingersetmessages: + msg355206
2019-10-22 18:11:42asvetlovsetmessages: + msg355144
2019-10-22 17:16:26srittausetmessages: + msg355142
2019-10-14 03:57:02rhettingersetassignee: rhettinger -> yselivanov
messages: + msg354614
2019-10-14 03:56:13rhettingersetmessages: - msg354595
2019-10-13 17:03:32rhettingersetassignee: docs@python -> rhettinger
messages: + msg354595
2019-10-13 15:58:24ned.deilysetnosy: + akuchling, rhettinger, asvetlov, yselivanov
2019-10-13 12:20:54srittaucreate