classification
Title: ‘memset’ offset [17, 88] from the object at ‘addrbuf’ is out of the bounds of referenced subobject
Type: Stage: resolved
Components: Versions: Python 3.8
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: christian.heimes, lukasz.langa, pablogsal, vstinner
Priority: normal Keywords:

Created on 2019-10-12 19:11 by pablogsal, last changed 2019-10-12 19:18 by pablogsal. This issue is now closed.

Messages (2)
msg354547 - (view) Author: Pablo Galindo Salgado (pablogsal) * (Python committer) Date: 2019-10-12 19:11
Compiling 3.8 in release mode emits this warning:

In function ‘getsockaddrarg’,
    inlined from ‘sock_bind’ at /home/pablogsal/github/python/3.8/Modules/socketmodule.c:3066:10:
/home/pablogsal/github/python/3.8/Modules/socketmodule.c:2288:9: warning: ‘memset’ offset [17, 88] from the object at ‘addrbuf’ is out of the bounds of referenced subobject ‘sa’ with type ‘struct sockaddr’ at offset 0 [-Warray-bounds]
 2288 |         memset(sa, 0, sizeof(*sa));
      |         ^~~~~~~~~~~~~~~~~~~~~~~~~~
msg354549 - (view) Author: Pablo Galindo Salgado (pablogsal) * (Python committer) Date: 2019-10-12 19:18
Duplicate of https://bugs.python.org/issue38282
History
Date User Action Args
2019-10-12 19:18:52pablogsalsetstatus: open -> closed
resolution: duplicate
messages: + msg354549

stage: resolved
2019-10-12 19:17:59pablogsalsetnosy: + christian.heimes
2019-10-12 19:11:40pablogsalcreate