classification
Title: test_concurrent_futures: reap_children() reaped child process 26487 on AMD64 RHEL8 Refleaks 3.x
Type: Stage: resolved
Components: Tests Versions: Python 3.9
process
Status: closed Resolution: duplicate
Dependencies: Superseder: test_concurrent_futures: reap_children() warnings on RHEL7 and RHEL8 buildbots
View: 38546
Assigned To: Nosy List: vstinner
Priority: normal Keywords:

Created on 2019-10-11 13:08 by vstinner, last changed 2019-10-24 09:18 by vstinner. This issue is now closed.

Messages (2)
msg354448 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2019-10-11 13:08
AMD64 RHEL8 Refleaks 3.x:
https://buildbot.python.org/all/#/builders/272/builds/23

0:27:13 load avg: 4.88 [416/419/1] test_concurrent_futures failed (env changed) (17 min 11 sec) -- running: test_capi (7 min 28 sec), test_gdb (8 min 49 sec), test_asyncio (23 min 23 sec)
beginning 6 repetitions
123456
.Warning -- reap_children() reaped child process 26487
.....
Warning -- multiprocessing.process._dangling was modified by test_concurrent_futures
  Before: set()
  After:  {<weakref at 0x7fdc08f44e30; to 'SpawnProcess' at 0x7fdc0a467c30>}
msg355311 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2019-10-24 09:18
I close this issue as a duplicate of bpo-38546.
History
Date User Action Args
2019-10-24 09:18:56vstinnersetstatus: open -> closed
superseder: test_concurrent_futures: reap_children() warnings on RHEL7 and RHEL8 buildbots
messages: + msg355311

resolution: duplicate
stage: resolved
2019-10-11 13:08:53vstinnercreate