classification
Title: 2.7.17rc1 tcl/tk version regression on Windows
Type: Stage: resolved
Components: Build, Installation, Tkinter, Windows Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: benjamin.peterson, ned.deily, paul.moore, serhiy.storchaka, steve.dower, terry.reedy, tim.golden, zach.ware
Priority: release blocker Keywords:

Created on 2019-10-10 16:17 by terry.reedy, last changed 2019-10-19 21:05 by steve.dower. This issue is now closed.

Messages (6)
msg354394 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2019-10-10 16:17
In my current 2.7.16+ Windows 10-64 repository build, and on at least one 8.1-64 buildbot, the tcl/tk version is 8.5.19
>>> tk.Tk().tk.call('info', 'patchlevel')
'8.5.19'

In my installed 2.7.17rc1, it is the older 8.5.15.  It would seem to me that we should install the same latest 8.5 bugfix release that we test with.  (Or test with what we release ;-)  I presume the discrepancy is unintended due to an incomplete final 2.7 tcl/tk update.
msg354911 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2019-10-18 16:46
What's the status of this release blocker?  Is there something that needs to be done for 2.7.17final which is imminent?
msg354912 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2019-10-18 16:48
Unless this actually regresses functionality, it doesn't seem like this needs to block the release.
msg354916 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2019-10-18 18:44
Since 8.5.19 is the version specified in the build config, that really ought to be the version we ship.  I would guess that it just didn't get rebuilt when Steve built the installer for 2.7.17rc1; should just be a matter of making sure it does for the real thing.
msg354917 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2019-10-18 19:57
Strange, I definitely cleaned up the externals before building 2.7.17rc1, so not sure how it ended up with the previous one.

I'll double-check later today on my build machine, but there shouldn't have to be any code changes to deal with this.
msg354968 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2019-10-19 21:05
Confirmed that it was a failed clean/rebuild on my build machine. The current build for 2.7.17 has the newer version.
History
Date User Action Args
2019-10-19 21:05:20steve.dowersetstatus: open -> closed
resolution: not a bug
messages: + msg354968

stage: resolved
2019-10-18 19:57:16steve.dowersetmessages: + msg354917
2019-10-18 18:44:19zach.waresetnosy: + paul.moore, tim.golden, steve.dower
messages: + msg354916
components: + Installation, Windows
2019-10-18 16:48:37benjamin.petersonsetmessages: + msg354912
2019-10-18 16:46:22ned.deilysetnosy: + ned.deily
messages: + msg354911
2019-10-10 16:17:42terry.reedycreate