classification
Title: Building with macoS system SQLite3 generates sqlite3_enable_shared_cache deprecation warning
Type: compile error Stage: resolved
Components: Build, macOS Versions: Python 3.9
process
Status: closed Resolution: duplicate
Dependencies: Superseder: "sqlite3_enable_shared_cache" deprecation warning when compiling with macOS system SQLite3
View: 24464
Assigned To: Nosy List: devnexen, ned.deily, ronaldoussoren
Priority: normal Keywords:

Created on 2019-09-28 21:17 by devnexen, last changed 2019-09-29 06:35 by ned.deily. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 16469 closed devnexen, 2019-09-28 21:17
Messages (2)
msg353485 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2019-09-29 06:11
Thanks for the PR!  As noted in my review comment of it, I believe a more robust approach would be needed to ensure that builds still work properly when building with a local copy of SQLite on macOS (not the system-supplied one), a common occurrence.
msg353486 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2019-09-29 06:35
Sorry, I should have checked: this issue has come up at least a couple of times before, for example, Issue30646 and Issue24464 (still open with a slightly more compex patch). Let's just close this issue as a duplicate of the earlier one and continue any new discussion there.
History
Date User Action Args
2019-09-29 06:35:27ned.deilysetstatus: open -> closed
superseder: "sqlite3_enable_shared_cache" deprecation warning when compiling with macOS system SQLite3
messages: + msg353486

resolution: duplicate
stage: patch review -> resolved
2019-09-29 06:11:52ned.deilysettitle: macOS sqlite 3 module build fix -> Building with macoS system SQLite3 generates sqlite3_enable_shared_cache deprecation warning
nosy: + ronaldoussoren, ned.deily

messages: + msg353485

components: + macOS
stage: patch review
2019-09-28 21:17:09devnexencreate