classification
Title: Got an compile failed info about typeobject.c
Type: compile error Stage: resolved
Components: Interpreter Core Versions: Python 3.9
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: petr.viktorin, shihai1991, vstinner
Priority: normal Keywords:

Created on 2019-09-25 11:22 by shihai1991, last changed 2019-09-25 13:55 by shihai1991. This issue is now closed.

Messages (4)
msg353178 - (view) Author: hai shi (shihai1991) * Date: 2019-09-25 11:22
Got an compile error, my OS is gcc version 4.8.5 20150623 (Red Hat 4.8.5-36:
 CC='gcc -pthread' LDSHARED='gcc -pthread -shared    ' OPT='-g -Og -Wall'       _TCLTK_INCLUDES='' _TCLTK_LIBS=''       ./python -E ./setup.py  build
python: Objects/typeobject.c:2867: PyType_FromSpecWithBases: Assertion `memb->type == 19' failed.
/bin/sh: line 9: 32047 Aborted                 CC='gcc -pthread' LDSHARED='gcc -pthread -shared    ' OPT='-g -Og -Wall' _TCLTK_INCLUDES='' _TCLTK_LIBS='' ./python -E ./setup.py $quiet build
make: *** [sharedmods] Error 134

the relevant bpo is https://bugs.python.org/issue38140, i have no enough time see the detail, so just report it for now.
msg353180 - (view) Author: Petr Viktorin (petr.viktorin) * (Python committer) Date: 2019-09-25 11:35
How are you building Python? Could you share your configure/make commands?
msg353181 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2019-09-25 11:35
Hi, can you please try to rebuild from scratch? For example, if you cloned the Git repository, revert all changes and remove all untracked files using:

  git checkout master .
  git clean -fdx

Otherwise, try:

  make distclean

Then try a new build.
msg353196 - (view) Author: hai shi (shihai1991) * Date: 2019-09-25 13:55
oh, thanks, guys. This error info is disappeared when i followed victor's advice. It must be i changed the configure/make file by accident.

Sorry for this noisy info
History
Date User Action Args
2019-09-25 13:55:09shihai1991setstatus: open -> closed
resolution: not a bug
messages: + msg353196

stage: resolved
2019-09-25 11:35:24vstinnersetnosy: + vstinner
messages: + msg353181
2019-09-25 11:35:11petr.viktorinsetnosy: + petr.viktorin
messages: + msg353180
2019-09-25 11:22:40shihai1991create