classification
Title: Unclear definition of ceil, floor and trunc in documentation mathmodule.c
Type: enhancement Stage: resolved
Components: Documentation Versions: Python 3.9
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Vocabulary: Using "integral" in library/stdtypes.html
View: 26512
Assigned To: docs@python Nosy List: Sophie, docs@python, serhiy.storchaka
Priority: normal Keywords:

Created on 2019-09-25 07:00 by Sophie, last changed 2019-09-25 07:07 by serhiy.storchaka. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 16279 Sophie, 2019-09-25 07:00
Messages (2)
msg353151 - (view) Author: Sophie (Sophie) * Date: 2019-09-25 07:00
The functions ceil(), floor() and trunc() define their result as an Integral. But an Integral is the result of an integration calculation. Better say Integer IMHO.
msg353153 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2019-09-25 07:07
The word "integral" has also other meaning.

This is a duplicate of issue26512.
History
Date User Action Args
2019-09-25 07:07:32serhiy.storchakasetstatus: open -> closed

superseder: Vocabulary: Using "integral" in library/stdtypes.html

nosy: + serhiy.storchaka
messages: + msg353153
resolution: duplicate
stage: resolved
2019-09-25 07:00:11Sophiecreate