classification
Title: Tkinter CheckButton default label white in macOS dark mode
Type: behavior Stage: resolved
Components: macOS, Tkinter Versions: Python 3.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Tkinter colours wrong on MacOS universal2
View: 42541
Assigned To: ned.deily Nosy List: Ryang Sohn, ned.deily, ronaldoussoren
Priority: normal Keywords:

Created on 2019-09-24 04:35 by Ryang Sohn, last changed 2020-12-03 15:57 by ronaldoussoren. This issue is now closed.

Files
File name Uploaded Description Edit
tkinter_checkbox.py Ryang Sohn, 2019-09-24 04:35 The minimum source file to validate the issue.
Messages (4)
msg353056 - (view) Author: Ryang Sohn (Ryang Sohn) Date: 2019-09-24 04:35
In macOS, when "Dark Mode" is turned on, TKinter's checkbutton's default label color is white, not black.
msg353060 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2019-09-24 06:55
I assume you are using a Python 3.7.x from a python.org macOS installer? Support for macOS dark mode is almost entirely a Tk issue as Tkinter is basically a shallow wrapper around Tk-provided APIs. We have been shipping Tk 8.6.8, s stable, slightly out-of-date version because it seemed to have the least number of issues across all of the macOS versions we support. With macOS 10.15 coming soon, I will shortly be taking another look st the latest unreleased Tk which may also have better support for dark mode.
msg381125 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2020-11-16 17:11
The same behaviour can be observed with Tk 8.6.10 build on macOS 11.

IMHO the problem is not so much that the default text color changes, but that the background color of the window does not change, it stays the same light color as in light mode. 

According to the Tk wiki <https://wiki.tcl-lang.org/page/Tk+differences+on+Mac+OS+X> the background color should adjust itself automatically.  I don't know if Tkinter does something that affects this.
msg382422 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2020-12-03 15:57
This is a duplicate of #42541.
History
Date User Action Args
2020-12-03 15:57:12ronaldoussorensetstatus: open -> closed
superseder: Tkinter colours wrong on MacOS universal2
messages: + msg382422

resolution: duplicate
stage: resolved
2020-11-16 17:11:47ronaldoussorensetmessages: + msg381125
2019-09-24 06:55:02ned.deilysetassignee: ned.deily
messages: + msg353060
2019-09-24 04:35:40Ryang Sohncreate