classification
Title: test_asyncio: SubprocessMultiLoopWatcherTests.test_stdin_stdout() failed on AMD64 FreeBSD 10-STABLE Non-Debug 3.x
Type: Stage: resolved
Components: asyncio, Tests Versions: Python 3.9, Python 3.8
process
Status: closed Resolution: duplicate
Dependencies: Superseder: asyncio: MultiLoopWatcher has a race condition (test_asyncio: test_close_kill_running() hangs on AMD64 RHEL7 Refleaks 3.x)
View: 38323
Assigned To: Nosy List: asvetlov, vstinner, yselivanov
Priority: normal Keywords:

Created on 2019-09-16 07:28 by vstinner, last changed 2020-02-07 10:53 by vstinner. This issue is now closed.

Messages (3)
msg352521 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2019-09-16 07:28
AMD64 FreeBSD 10-STABLE Non-Debug 3.x:
https://buildbot.python.org/all/#/builders/167/builds/1535

======================================================================
ERROR: test_stdin_stdout (test.test_asyncio.test_subprocess.SubprocessMultiLoopWatcherTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/home/buildbot/python/3.x.koobs-freebsd10.nondebug/build/Lib/test/test_asyncio/test_subprocess.py", line 129, in test_stdin_stdout
    exitcode, stdout = self.loop.run_until_complete(task)
  File "/usr/home/buildbot/python/3.x.koobs-freebsd10.nondebug/build/Lib/asyncio/base_events.py", line 608, in run_until_complete
    return future.result()
  File "/usr/home/buildbot/python/3.x.koobs-freebsd10.nondebug/build/Lib/asyncio/tasks.py", line 490, in wait_for
    raise exceptions.TimeoutError()
asyncio.exceptions.TimeoutError

and then when asyncio is re-run in verbose mode:

ERROR: test_stdin_stdout (test.test_asyncio.test_subprocess.SubprocessMultiLoopWatcherTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/home/buildbot/python/3.x.koobs-freebsd10.nondebug/build/Lib/test/test_asyncio/test_subprocess.py", line 129, in test_stdin_stdout
    exitcode, stdout = self.loop.run_until_complete(task)
  File "/usr/home/buildbot/python/3.x.koobs-freebsd10.nondebug/build/Lib/asyncio/base_events.py", line 608, in run_until_complete
    return future.result()
  File "/usr/home/buildbot/python/3.x.koobs-freebsd10.nondebug/build/Lib/asyncio/tasks.py", line 490, in wait_for
    raise exceptions.TimeoutError()
asyncio.exceptions.TimeoutError
msg352522 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2019-09-16 07:31
Python 3.8 also has SubprocessMultiLoopWatcherTests so it's also likely affected.

I ran this command for 1 minute on my Linux laptop, it didn't fail:

# my laptop has 8 logical CPUs
$ ./python -m test test_asyncio -m SubprocessMultiLoopWatcherTests -j20 -F -v
msg361575 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2020-02-07 10:53
I mark this issue as a duplicate of bpo-38323.
History
Date User Action Args
2020-02-07 10:53:52vstinnersetstatus: open -> closed
superseder: asyncio: MultiLoopWatcher has a race condition (test_asyncio: test_close_kill_running() hangs on AMD64 RHEL7 Refleaks 3.x)
messages: + msg361575

resolution: duplicate
stage: resolved
2019-09-16 07:31:43vstinnersetmessages: + msg352522
versions: + Python 3.8
2019-09-16 07:29:19vstinnersettitle: test_asyncio.test_subprocess: test_stdin_stdout() failed on AMD64 FreeBSD 10-STABLE Non-Debug 3.x -> test_asyncio: SubprocessMultiLoopWatcherTests.test_stdin_stdout() failed on AMD64 FreeBSD 10-STABLE Non-Debug 3.x
2019-09-16 07:28:52vstinnercreate