classification
Title: ftplib: ABOR does not consider 225 response code
Type: behavior Stage: resolved
Components: Versions: Python 3.1, Python 3.2, Python 2.7, Python 2.6
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: giampaolo.rodola Nosy List: facundobatista, giampaolo.rodola
Priority: normal Keywords: patch

Created on 2008-09-09 13:56 by giampaolo.rodola, last changed 2010-04-18 13:55 by giampaolo.rodola. This issue is now closed.

Files
File name Uploaded Description Edit
ftplib.patch giampaolo.rodola, 2008-09-09 13:56
Messages (4)
msg72859 - (view) Author: Giampaolo Rodola' (giampaolo.rodola) * (Python committer) Date: 2008-09-09 13:56
RFC-959 at chapter 5.4 includes 225 as a possible response to an ABOR
command.
225 should be sent by server when a client issues an ABOR command and
there's no data transfer to abort.
The patch in attachment includes 225 code in the list of positive ABOR
response codes.


[1] http://www.ietf.org/rfc/rfc0959.txt
msg72894 - (view) Author: Facundo Batista (facundobatista) * (Python committer) Date: 2008-09-09 19:04
Giampaolo, should we close this one as duplicate of 3818 (that you
created one minute later)?
msg72934 - (view) Author: Giampaolo Rodola' (giampaolo.rodola) * (Python committer) Date: 2008-09-10 00:41
No, Georg Brandl already closed that one.
Sorry for the duplicate, it was accidental.
msg103490 - (view) Author: Giampaolo Rodola' (giampaolo.rodola) * (Python committer) Date: 2010-04-18 13:55
Fixed as r80172 (python 2.7) and r80176 (python 3.2).
History
Date User Action Args
2010-04-18 13:55:27giampaolo.rodolasetstatus: open -> closed
priority: normal

assignee: giampaolo.rodola
versions: + Python 2.6, Python 3.1, Python 2.7, Python 3.2
messages: + msg103490
type: behavior
resolution: fixed
stage: resolved
2008-09-10 00:41:31giampaolo.rodolasetmessages: + msg72934
2008-09-09 20:32:57georg.brandllinkissue3818 superseder
2008-09-09 19:04:32facundobatistasetnosy: + facundobatista
messages: + msg72894
2008-09-09 13:56:26giampaolo.rodolacreate