classification
Title: Make select module PEP-384 compatible
Type: enhancement Stage: resolved
Components: Extension Modules Versions: Python 3.9
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: dino.viehland Nosy List: BTaskaya, christian.heimes, dino.viehland, eric.snow, josh.r, phsilva, vstinner
Priority: normal Keywords: patch

Created on 2019-09-11 14:48 by dino.viehland, last changed 2020-06-22 09:28 by vstinner. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 15971 merged dino.viehland, 2019-09-11 14:49
Messages (6)
msg351913 - (view) Author: Dino Viehland (dino.viehland) * (Python committer) Date: 2019-09-11 14:48
Remove static PyTypeObject* definitions and move static data to _selectstate to help improve compatibility w/ subinterpreters and re-use by alternate implementations.
msg352017 - (view) Author: Josh Rosenberg (josh.r) * (Python triager) Date: 2019-09-11 19:09
Why do you describe these issues (this one, #38069, #38071-#38076, maybe more) as making the module PEP 384 compatible? There is no reason to make the built-in modules stick to the limited API, and it doesn't look like you're doing that in any event (among other things, pretty sure Argument Clinic generated code isn't limited API compatible yet, though that might be changing?).

Seems like the main (only?) change you're making is to convert all static types to dynamic types. Which is fine, if it's necessary for PEP 554, but it seems only loosely related to PEP 384 (which defined mechanisms for "statically" defining dynamic heap types, but that wasn't the main thrust).
msg352431 - (view) Author: Dino Viehland (dino.viehland) * (Python committer) Date: 2019-09-14 14:20
New changeset f919054e539a5c1afde1b31c9fd7a8f5b2313311 by Dino Viehland in branch 'master':
bpo-38116: Convert select module to PEP-384 (#15971)
https://github.com/python/cpython/commit/f919054e539a5c1afde1b31c9fd7a8f5b2313311
msg356825 - (view) Author: Batuhan Taskaya (BTaskaya) * (Python triager) Date: 2019-11-17 18:37
PR 15971 is merged, what else is needed @dino.viehland?
msg372058 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2020-06-22 09:14
> PR 15971 is merged, what else is needed @dino.viehland?

Nothing, I close the issue.
msg372070 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2020-06-22 09:28
I marked bpo-15703 as a duplicate of this issue.
History
Date User Action Args
2020-06-22 09:28:51vstinnersetmessages: + msg372070
2020-06-22 09:28:36vstinnerlinkissue15703 superseder
2020-06-22 09:14:47vstinnersetstatus: open -> closed

nosy: + vstinner
messages: + msg372058

resolution: fixed
stage: patch review -> resolved
2019-11-17 18:37:57BTaskayasetnosy: + BTaskaya
messages: + msg356825
2019-09-19 04:03:39phsilvasetnosy: + phsilva
2019-09-14 14:20:30dino.viehlandsetmessages: + msg352431
2019-09-11 19:09:45josh.rsetnosy: + josh.r
messages: + msg352017
2019-09-11 18:00:44christian.heimessetnosy: + christian.heimes
type: enhancement
2019-09-11 14:49:01dino.viehlandsetkeywords: + patch
stage: patch review
pull_requests: + pull_request15604
2019-09-11 14:48:15dino.viehlandcreate