classification
Title: wsgiref.simple_server fails to run demo_app
Type: Stage:
Components: Library (Lib) Versions: Python 3.0
process
Status: closed Resolution: duplicate
Dependencies: Superseder: wsgiref package totally broken
View: 4718
Assigned To: Nosy List: Walling, pitrou
Priority: normal Keywords:

Created on 2008-09-06 19:38 by Walling, last changed 2008-12-22 16:27 by pitrou. This issue is now closed.

Messages (2)
msg72684 - (view) Author: Bjarke Walling (Walling) Date: 2008-09-06 19:38
To reproduce the error start Python 3.0 and enter the usual WSGI "hello
world" application:

>>> from wsgiref.simple_server import make_server, demo_app
>>> httpd = make_server('', 8000, demo_app)
>>> httpd.serve_forever()

Open a browser and point it at http://location:8000/. On each HTTP
request an exception will be thrown:

----------------------------------------
Exception happened during processing of request from ('127.0.0.1', 55779)
Traceback (most recent call last):
  File "/usr/local/lib/python3.0/socketserver.py", line 281, in
_handle_request_noblock
    self.process_request(request, client_address)
  File "/usr/local/lib/python3.0/socketserver.py", line 307, in
process_request
    self.finish_request(request, client_address)
  File "/usr/local/lib/python3.0/socketserver.py", line 320, in
finish_request
    self.RequestHandlerClass(request, client_address, self)
  File "/usr/local/lib/python3.0/socketserver.py", line 614, in __init__
    self.handle()
  File "/usr/local/lib/python3.0/wsgiref/simple_server.py", line 136, in
handle
    self.rfile, self.wfile, self.get_stderr(), self.get_environ()
  File "/usr/local/lib/python3.0/wsgiref/simple_server.py", line 115, in
get_environ
    k,v = h.split(':',1)
ValueError: need more than 1 value to unpack
----------------------------------------

Expected result: The nice demo page containing WSGI environment
variables is displayed in the browser.
msg72704 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2008-09-06 21:33
This seems to be a duplicate of #3348.
History
Date User Action Args
2008-12-22 16:27:43pitrousetsuperseder: wsgiref package totally broken
2008-09-06 21:33:42pitrousetstatus: open -> closed
resolution: duplicate
messages: + msg72704
nosy: + pitrou
2008-09-06 19:38:14Wallingcreate