classification
Title: MacOS crash appJar 3.7.3
Type: crash Stage: resolved
Components: macOS Versions: Python 3.7
process
Status: closed Resolution: third party
Dependencies: Superseder:
Assigned To: Nosy List: Michael Hearn, ronaldoussoren
Priority: normal Keywords:

Created on 2019-08-16 17:52 by Michael Hearn, last changed 2019-08-16 21:10 by Michael Hearn. This issue is now closed.

Messages (4)
msg349880 - (view) Author: Michael Hearn (Michael Hearn) Date: 2019-08-16 19:36
macOS 10.14.6 -anaconda install Python 3.7.3  pip install appJar (0.94.0) 

On start of app with app.go() a crash will occur causing mac to logout.

Python 3.7.2 does not show this behavior

Will document on medium.

https://raw.githubusercontent.com/borosilicate/RCSB-Protein-Data-Bank-CSV-Maker/master/pygui.py
msg349882 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2019-08-16 19:55
Does this application use Tkinter?  

If so, this is a duplicate of #37833, and a bug in macOS triggered by (amongst others) anaconda but (AFAIK) not by the Python.org installer.

The "logout" is a crash in the WindowServer proces, which is something that should never happen. I've filed an issue with Apple about that, but have no idea if or when they will look at that.
msg349885 - (view) Author: Michael Hearn (Michael Hearn) Date: 2019-08-16 20:42
Thanks for the fast response it uses appJar which is a very similar GUI
package but not the same one. AppJar is based of it but I don’t believe it
was built off it.

On Fri, Aug 16, 2019 at 3:55 PM Ronald Oussoren <report@bugs.python.org>
wrote:

>
> Ronald Oussoren <ronaldoussoren@mac.com> added the comment:
>
> Does this application use Tkinter?
>
> If so, this is a duplicate of #37833, and a bug in macOS triggered by
> (amongst others) anaconda but (AFAIK) not by the Python.org installer.
>
> The "logout" is a crash in the WindowServer proces, which is something
> that should never happen. I've filed an issue with Apple about that, but
> have no idea if or when they will look at that.
>
> ----------
> nosy: +ronaldoussoren
>
> _______________________________________
> Python tracker <report@bugs.python.org>
> <https://bugs.python.org/issue37877>
> _______________________________________
>
msg349887 - (view) Author: Michael Hearn (Michael Hearn) Date: 2019-08-16 21:10
Hopefully apple will fix this.
https://medium.com/@michaeljosephhearn/macos-mojave-crash-6fd1e69d3d34
History
Date User Action Args
2019-08-16 21:10:23Michael Hearnsetmessages: + msg349887
2019-08-16 20:56:17Michael Hearnsetstatus: open -> closed
resolution: third party
stage: resolved
2019-08-16 20:42:50Michael Hearnsetmessages: + msg349885
2019-08-16 19:55:26ronaldoussorensetnosy: + ronaldoussoren
messages: + msg349882
2019-08-16 19:36:39Michael Hearnsetnosy: - ronaldoussoren, ned.deily
type: crash
messages: + msg349880
2019-08-16 17:52:04Michael Hearncreate