classification
Title: int returns error (SystemError)
Type: crash Stage: resolved
Components: Interpreter Core Versions: Python 3.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Philippe Négrel, eric.smith, paul.moore, steve.dower, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2019-08-07 10:08 by Philippe Négrel, last changed 2019-08-07 10:19 by Philippe Négrel. This issue is now closed.

Messages (3)
msg349158 - (view) Author: Philippe Négrel (Philippe Négrel) Date: 2019-08-07 10:08
Whenever I compile the code, I get this error:

Exception has occurred: SystemError
<class 'int'> returned a result with an error set

This issue occured at line 32 of the file "SaveTools.py" in this github branch:
https://github.com/l3alr0g/Wave-simulator/tree/python-bug-report
(sry I couldn't get the 'Github PR' option to work)
msg349160 - (view) Author: Eric V. Smith (eric.smith) * (Python committer) Date: 2019-08-07 10:17
This looks like a problem in pandas.

If you can distill this down to a short python program that doesn't include any third party libraries, then we can take a look at it.

Otherwise, I suggest reporting it on the pandas bug tracker.
msg349161 - (view) Author: Philippe Négrel (Philippe Négrel) Date: 2019-08-07 10:19
My bad the compilation Error came from the panda3d engine, which affected in some way the int class, issue solved, sry for wasting your time X)
History
Date User Action Args
2019-08-07 10:19:41Philippe Négrelsetstatus: pending -> closed
resolution: third party -> not a bug
messages: + msg349161

stage: test needed -> resolved
2019-08-07 10:17:20eric.smithsetstatus: open -> pending

type: compile error -> crash
components: + Interpreter Core, - Windows

nosy: + eric.smith
messages: + msg349160
resolution: third party
stage: test needed
2019-08-07 10:08:54Philippe Négrelcreate