classification
Title: test_with_pip fails on FreeBSD 10 bot
Type: behavior Stage: resolved
Components: Tests Versions: Python 3.9, Python 3.8
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: Marcus.Smith, dstufft, koobs, ncoghlan, pablogsal, paul.moore, pradyunsg, steve.dower, vstinner, xtreak
Priority: normal Keywords:

Created on 2019-07-25 10:07 by xtreak, last changed 2019-07-26 13:11 by steve.dower. This issue is now closed.

Messages (4)
msg348432 - (view) Author: Karthikeyan Singaravelan (xtreak) * (Python committer) Date: 2019-07-25 10:07
I guess the upgrade in issue37664 caused an issue with FreeBSD bot. The bot seems to fail after this change on master and 3.8.

https://buildbot.python.org/all/#/builders/167/builds/1380


test_with_pip (test.test_venv.EnsurePipTest) ... FAIL
======================================================================
FAIL: test_with_pip (test.test_venv.EnsurePipTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/home/buildbot/python/3.x.koobs-freebsd10.nondebug/build/Lib/test/test_venv.py", line 495, in test_with_pip
    self.do_test_with_pip(False)
  File "/usr/home/buildbot/python/3.x.koobs-freebsd10.nondebug/build/Lib/test/test_venv.py", line 478, in do_test_with_pip
    self.assertEqual(err.rstrip(), "")
AssertionError: "WARNING: The directory '/.cache/pip/http[202 chars]lag." != ''
- WARNING: The directory '/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
+ 
----------------------------------------------------------------------
msg348444 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2019-07-25 16:32
Guessing this is a new warning in pip?

Can we just disable the cache explicitly for these tests? Or should we reconfigure the buildbot to suppress the warning.
msg348483 - (view) Author: Kubilay Kocak (koobs) (Python triager) Date: 2019-07-26 08:15
Since this is likely a regression from issue 37664, which is still open, and also contains the report, I'd close this issue in favour of the former. Having regression reports in separate issues for still open in new/separate issues tends to results in them not being addressed in a timely manner.

If it turns out this is not related to the commits from issue 37664, this can be re-opened.

Having said that, these bots have been stable and green for a substantial amount of time, so in almost all cases (upgrades to the bots not withstanding), new regressions/failures are almost certainly newly introduced
msg348489 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2019-07-26 13:11
Could you please nosy yourself on the other issue and help us address it then?

The only change was upgrading pip, and the error is just a new warning message, but unless someone knows how bad it is then we'll "fix" it by ignoring the warning.
History
Date User Action Args
2019-07-26 13:11:05steve.dowersetmessages: + msg348489
2019-07-26 08:15:18koobssetstatus: open -> closed
resolution: duplicate
messages: + msg348483

stage: resolved
2019-07-25 16:36:48xtreaksetnosy: + koobs
2019-07-25 16:32:55steve.dowersetnosy: + Marcus.Smith, paul.moore, ncoghlan, dstufft, pradyunsg, steve.dower
messages: + msg348444
2019-07-25 10:07:19xtreakcreate