classification
Title: Set subset operator docs
Type: Stage: resolved
Components: Documentation Versions: Python 3.7, Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: Frank B2, aldwinaldwin, docs@python, rhettinger
Priority: normal Keywords:

Created on 2019-07-22 21:33 by Frank B2, last changed 2019-07-23 04:58 by rhettinger. This issue is now closed.

Files
File name Uploaded Description Edit
2019-07-22 1728 Screenshot.png Frank B2, 2019-07-22 21:33
Messages (3)
msg348307 - (view) Author: Frank B (Frank B2) * Date: 2019-07-22 21:33
The docs say "Test whether the set is a proper subset of other" for both set < other and set > other built-in functions.

Is that a misprint? How could it be both?

For the <= and >= operators it properly reverses the order so one says:

Test whether every element in the set is in other.

and the other:

Test whether every element in other is in the set.
msg348314 - (view) Author: Aldwin Pollefeyt (aldwinaldwin) * Date: 2019-07-23 02:39
For 'set < other' it says sub-set ... for 'set > other' is says super-set. Subset vs superset. So I think it's correct in the documentation.
msg348319 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2019-07-23 04:58
The docs look fine to me as well.
History
Date User Action Args
2019-07-23 04:58:44rhettingersetstatus: open -> closed
resolution: not a bug
messages: + msg348319

stage: resolved
2019-07-23 02:39:36aldwinaldwinsetnosy: + aldwinaldwin
messages: + msg348314
2019-07-23 01:51:53xtreaksetnosy: + rhettinger
2019-07-22 21:33:30Frank B2create