classification
Title: asyncore differences between 2.x and 3.x
Type: behavior Stage:
Components: Library (Lib) Versions: Python 2.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: josiahcarlson Nosy List: giampaolo.rodola, gregory.p.smith, josiah.carlson, josiahcarlson
Priority: release blocker Keywords: easy

Created on 2008-09-03 13:26 by giampaolo.rodola, last changed 2008-09-07 11:29 by giampaolo.rodola. This issue is now closed.

Messages (5)
msg72386 - (view) Author: Giampaolo Rodola' (giampaolo.rodola) * (Python committer) Date: 2008-09-03 13:26
I don't know if this is intentional but I point it out anyway in case
this is wrong (as I think):

asyncore.py of Python 2.6 trunk on line 104 contains:

        if flags & select.POLLHUP:
            obj.handle_close()

...while the python 3.0 version is different:

        if flags & select.POLLHUP:
            obj.handle_close_event()
msg72730 - (view) Author: Josiah Carlson (josiahcarlson) * (Python triager) Date: 2008-09-07 03:54
Fixed in 66281.
msg72731 - (view) Author: Gregory P. Smith (gregory.p.smith) * (Python committer) Date: 2008-09-07 04:29
please undo this, this broke asyncore in trunk.  handle_close_event 
doesn't exist in 2.6.
msg72732 - (view) Author: Josiah Carlson (josiahcarlson) * (Python triager) Date: 2008-09-07 04:44
I reverted the change I made to 2.6, see 66282.

The handle_close_event() method also doesn't exist in 3.0, which is why 
it (and the reference) were removed in revision 64883.  Giampaolo needs 
to update his Python 3.0 checkout.

Closing as invalid.
msg72737 - (view) Author: Giampaolo Rodola' (giampaolo.rodola) * (Python committer) Date: 2008-09-07 11:29
Sorry, my fault.
History
Date User Action Args
2008-09-07 11:29:45giampaolo.rodolasetmessages: + msg72737
2008-09-07 04:44:23josiahcarlsonsetstatus: open -> closed
resolution: not a bug
messages: + msg72732
2008-09-07 04:30:32gregory.p.smithsetkeywords: + easy
type: behavior
versions: + Python 2.6, - Python 3.0
2008-09-07 04:29:17gregory.p.smithsetstatus: closed -> open
nosy: + gregory.p.smith
resolution: fixed -> (no value)
messages: + msg72731
priority: release blocker
2008-09-07 03:54:33josiahcarlsonsetstatus: open -> closed
resolution: fixed
messages: + msg72730
2008-09-03 21:29:28benjamin.petersonsetassignee: josiahcarlson
2008-09-03 13:26:26giampaolo.rodolacreate