classification
Title: audit event table breaks PDF sphinx build
Type: Stage: resolved
Components: Versions:
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: mdk Nosy List: christian.heimes, mdk, steve.dower
Priority: normal Keywords: patch

Created on 2019-07-15 16:34 by mdk, last changed 2019-09-10 08:55 by mdk. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 15739 steve.dower, 2019-09-10 08:53
Messages (4)
msg347980 - (view) Author: Julien Palard (mdk) * (Python committer) Date: 2019-07-15 16:34
The following commit:

    44f91c388a6f4da9ed3300df32ca290b8aa104ea
    bpo-37390: Add audit event table to documentations (GH-14406)

    Also updates some (unreleased) event names to be consistent with the others.

breaks PDF builds.

Reproductible using:

    (cd Doc; sphinx-build -b latex -d build/doctrees -D latex_elements.papersize=a4 -D latex_engine=xelatex -D latex_elements.inputenc= -D latex_elements.fontenc=\\\\usepackage{xeCJK} -Ea -A daily=1 -A switchers=1  . build/latex)

The exception raised is "NoUri", I patched sphinx [1] to add a few info, so it is a "sphinx.errors.NoUri: c-api/code".



[1]: https://github.com/sphinx-doc/sphinx/pull/6583/files
msg348034 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2019-07-16 17:24
Guess we need a real Sphinx expert to help out here. 

Somehow we need to get explicit backlinks, but I couldn't figure out how to resolve them normally through an extension. If we can do that, this will probably go away.
msg348058 - (view) Author: Julien Palard (mdk) * (Python committer) Date: 2019-07-17 12:32
Looks like a failure during library.pdf, from why we try to link to c-api.

In the sphinx latex builder:

    if docname not in self.docnames:
        raise NoUri

in self.docnames during the library build, we're only having library/* links. So c-api/code is obviously not in it.
msg351092 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2019-09-03 17:57
Guessing we still need to fix this...

Julien - does this exception get raised through Doc/tools/extensions/pyspecific.py? At the get_relative_uri() call (line 573) perhaps?

If so, it seems like we could just handle it there and leave out any links that aren't in the doc.
History
Date User Action Args
2019-09-10 08:55:08mdksetstage: patch review -> resolved
2019-09-10 08:53:38steve.dowersetstatus: open -> closed
pull_requests: + pull_request15475
assignee: mdk
keywords: + patch
resolution: fixed
stage: patch review
2019-09-03 17:57:47steve.dowersetmessages: + msg351092
2019-07-17 12:32:13mdksetmessages: + msg348058
2019-07-16 17:24:55steve.dowersetmessages: + msg348034
2019-07-15 16:34:23mdkcreate