classification
Title: os problems on absolute paths containing unicode characters on windows
Type: Stage: resolved
Components: Windows Versions: Python 3.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Jonatã Bolzan Loss, paul.moore, steve.dower, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2019-06-14 11:01 by Jonatã Bolzan Loss, last changed 2019-06-14 11:39 by Jonatã Bolzan Loss. This issue is now closed.

Messages (3)
msg345580 - (view) Author: Jonatã Bolzan Loss (Jonatã Bolzan Loss) Date: 2019-06-14 11:01
If a absolute path is provided for some function on os module, it returns "WinError 3".

Example (considering you are on C:\Users\username):

import os                                                                                                           os.mkdir(u'Examşplü')
os.listdir(u'C:\\Users\username\Examşplü')

Result:

Traceback (most recent call last):                                                                                        File "<stdin>", line 1, in <module>                                                                                   FileNotFoundError: [WinError 3] The system cannot find the path specified: 'C:\\Users\\username\\Examşplü'
msg345583 - (view) Author: Paul Moore (paul.moore) * (Python committer) Date: 2019-06-14 11:07
This works for me on Python 3.7. Can you confirm if you see the problem on 3.7, and if so, provide a more detailed example of how to reproduce?
msg345587 - (view) Author: Jonatã Bolzan Loss (Jonatã Bolzan Loss) Date: 2019-06-14 11:39
You are right, my mistake. Sorry about this and thanks for checking :) .
History
Date User Action Args
2019-06-14 11:39:24Jonatã Bolzan Losssetstatus: open -> closed
resolution: not a bug
messages: + msg345587

stage: resolved
2019-06-14 11:07:06paul.mooresetmessages: + msg345583
2019-06-14 11:01:44Jonatã Bolzan Losscreate