classification
Title: test_asyncio: ProactorLoopCtrlC leaks one reference
Type: Stage: resolved
Components: asyncio, Tests Versions: Python 3.9, Python 3.8
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: asvetlov, miss-islington, vstinner, yselivanov
Priority: normal Keywords: patch

Created on 2019-06-14 10:19 by vstinner, last changed 2019-06-14 13:30 by asvetlov. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 14074 merged vstinner, 2019-06-14 10:21
PR 14077 closed miss-islington, 2019-06-14 11:03
PR 14078 merged miss-islington, 2019-06-14 11:33
Messages (7)
msg345570 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2019-06-14 10:19
vstinner@WIN C:\vstinner\python\master>python -m test -R 3:3 test_asyncio -m test.test_asyncio.test_windows_events.ProactorLoopCtrlC.test_ctrl_c
Running Debug|x64 interpreter...
Run tests sequentially
0:00:00 load avg: 0.00 [1/1] test_asyncio
beginning 6 repetitions
123456
......
test_asyncio leaked [1, 1, 1] references, sum=3
test_asyncio leaked [2, 1, 1] memory blocks, sum=4
test_asyncio failed

== Tests result: FAILURE ==

1 test failed:
    test_asyncio

Total duration: 13 sec 391 ms
Tests result: FAILURE



Attached PR fix the issue by joining the thread.
msg345573 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2019-06-14 10:26
bpo-34520 *might* be an old duplicate of this bug.
msg345579 - (view) Author: Andrew Svetlov (asvetlov) * (Python committer) Date: 2019-06-14 10:46
Maybe. Agree with your decision to close bpo-34520 as duplicate.
msg345581 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2019-06-14 11:03
New changeset 07559450b2d9179e4c99e0af088ce7550e549f94 by Victor Stinner in branch 'master':
bpo-37278: Fix test_asyncio ProactorLoopCtrlC (GH-14074)
https://github.com/python/cpython/commit/07559450b2d9179e4c99e0af088ce7550e549f94
msg345588 - (view) Author: miss-islington (miss-islington) Date: 2019-06-14 11:53
New changeset 8b66dbb212d7dffbf9fb545dad2a3400aead1461 by Miss Islington (bot) in branch '3.8':
bpo-37278: Fix test_asyncio ProactorLoopCtrlC (GH-14074)
https://github.com/python/cpython/commit/8b66dbb212d7dffbf9fb545dad2a3400aead1461
msg345590 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2019-06-14 12:15
Thanks for the review Andrew.
msg345594 - (view) Author: Andrew Svetlov (asvetlov) * (Python committer) Date: 2019-06-14 13:30
Welcome!
Thanks for the fix!
History
Date User Action Args
2019-06-14 13:30:48asvetlovsetmessages: + msg345594
2019-06-14 12:15:46vstinnersetmessages: + msg345590
2019-06-14 12:15:31vstinnersetstatus: open -> closed
resolution: fixed
stage: patch review -> resolved
2019-06-14 11:53:19miss-islingtonsetnosy: + miss-islington
messages: + msg345588
2019-06-14 11:33:36miss-islingtonsetpull_requests: + pull_request13936
2019-06-14 11:03:24miss-islingtonsetpull_requests: + pull_request13935
2019-06-14 11:03:06vstinnersetmessages: + msg345581
2019-06-14 10:46:22asvetlovsetmessages: + msg345579
2019-06-14 10:26:43vstinnersetmessages: + msg345573
2019-06-14 10:21:19vstinnersetkeywords: + patch
stage: patch review
pull_requests: + pull_request13932
2019-06-14 10:19:11vstinnercreate