classification
Title: test_sendfile in asyncio crashes when os.sendfile() is not supported
Type: Stage: resolved
Components: Versions:
process
Status: closed Resolution:
Dependencies: Superseder:
Assigned To: Nosy List: Michael.Felt
Priority: normal Keywords: patch

Created on 2019-06-12 10:05 by Michael.Felt, last changed 2019-06-19 08:17 by Michael.Felt. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 14010 closed Michael.Felt, 2019-06-12 10:50
Messages (2)
msg345314 - (view) Author: Michael Felt (Michael.Felt) * Date: 2019-06-12 10:05
issue34655 added sendfile support to asyncio. However, the `test_sendfile` fails when called if there is no os.sendfile support.

This patch will skip the test when 

@unittest.skipUnless(hasattr(os, 'sendfile'), 'test needs os.sendfile()')
msg346028 - (view) Author: Michael Felt (Michael.Felt) * Date: 2019-06-19 08:17
Closed. Not a bug in test_sendfile.
History
Date User Action Args
2019-06-19 08:17:38Michael.Feltsetstatus: open -> closed

messages: + msg346028
stage: patch review -> resolved
2019-06-12 10:50:17Michael.Feltsetkeywords: + patch
stage: patch review
pull_requests: + pull_request13874
2019-06-12 10:05:34Michael.Feltcreate