classification
Title: Test with OpenSSL 1.1.1c
Type: enhancement Stage: resolved
Components: asyncio, SSL, Tests Versions: Python 3.9, Python 3.8, Python 3.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: test_asyncio: test_start_tls_server_1() TimeoutError on Fedora 29
View: 35998
Assigned To: christian.heimes Nosy List: asvetlov, christian.heimes, cstratak, miss-islington, ned.deily, yselivanov
Priority: high Keywords: patch

Created on 2019-05-28 15:44 by christian.heimes, last changed 2019-06-14 14:04 by asvetlov. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 13631 merged christian.heimes, 2019-05-28 16:11
PR 13782 merged miss-islington, 2019-06-03 18:10
Messages (9)
msg343797 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2019-05-28 15:44
OpenSSL 1.1.1c is out, https://github.com/openssl/openssl/blob/OpenSSL_1_1_1c/CHANGES
msg343798 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2019-05-28 16:10
test_start_tls_server_1 is failing reproducible with OpenSSL 1.1.1c on Linux (Fedora 29).

======================================================================
ERROR: test_start_tls_server_1 (test.test_asyncio.test_sslproto.SelectorStartTLSTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/heimes/dev/python/cpython/Lib/test/test_asyncio/test_sslproto.py", line 577, in test_start_tls_server_1
    self.loop.run_until_complete(run_main())
  File "/home/heimes/dev/python/cpython/Lib/asyncio/base_events.py", line 608, in run_until_complete
    return future.result()
  File "/home/heimes/dev/python/cpython/Lib/test/test_asyncio/test_sslproto.py", line 570, in run_main
    await asyncio.wait_for(
  File "/home/heimes/dev/python/cpython/Lib/asyncio/tasks.py", line 461, in wait_for
    raise exceptions.TimeoutError()
asyncio.exceptions.TimeoutError
msg343799 - (view) Author: Charalampos Stratakis (cstratak) * Date: 2019-05-28 16:14
Reported here: https://bugs.python.org/issue35998
msg343801 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2019-05-28 16:18
Ah, thanks! I forgot about that bug.

The test suite is aready failing with OpenSSL 1.1.1b.
msg343802 - (view) Author: Charalampos Stratakis (cstratak) * Date: 2019-05-28 16:20
Also those failures are recorded on the Fedora buildbot, it seems to be happening randomly: https://buildbot.python.org/all/#/workers/32
msg343850 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2019-05-29 01:37
Should we update the Windows and Mac installers to 1.1.1c now?
msg344455 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2019-06-03 18:10
New changeset 06651ee418b5e4e013195d6b702763a1220706a7 by Christian Heimes in branch 'master':
bpo-37081: Test with OpenSSL 1.1.1c (GH-13631)
https://github.com/python/cpython/commit/06651ee418b5e4e013195d6b702763a1220706a7
msg344458 - (view) Author: miss-islington (miss-islington) Date: 2019-06-03 18:40
New changeset 3344197040fe1b05a3244bdb16d429f4647f35b8 by Miss Islington (bot) in branch '3.7':
[3.7] bpo-37081: Test with OpenSSL 1.1.1c (GH-13631) (GH-13782)
https://github.com/python/cpython/commit/3344197040fe1b05a3244bdb16d429f4647f35b8
msg345595 - (view) Author: Andrew Svetlov (asvetlov) * (Python committer) Date: 2019-06-14 14:04
Duplicate of #35998
History
Date User Action Args
2019-06-14 14:04:48asvetlovsetstatus: open -> closed
superseder: test_asyncio: test_start_tls_server_1() TimeoutError on Fedora 29
messages: + msg345595

resolution: duplicate
stage: patch review -> resolved
2019-06-03 18:40:01miss-islingtonsetnosy: + miss-islington
messages: + msg344458
2019-06-03 18:10:40miss-islingtonsetpull_requests: + pull_request13667
2019-06-03 18:10:25christian.heimessetmessages: + msg344455
2019-05-29 01:37:04ned.deilysetnosy: + ned.deily
messages: + msg343850
2019-05-28 16:20:14cstrataksetmessages: + msg343802
2019-05-28 16:18:28christian.heimessetmessages: + msg343801
2019-05-28 16:14:34cstrataksetnosy: + cstratak
messages: + msg343799
2019-05-28 16:11:44christian.heimessetkeywords: + patch
stage: patch review
pull_requests: + pull_request13531
2019-05-28 16:10:44christian.heimessetnosy: + asvetlov, yselivanov
messages: + msg343798

components: + asyncio
type: enhancement
2019-05-28 15:44:52christian.heimescreate