classification
Title: suspicious.py sphinx extension access non-existing attribute.
Type: Stage: resolved
Components: Documentation Versions: Python 3.8
process
Status: closed Resolution: duplicate
Dependencies: Superseder: inconsistencies in docs builds (Sphinx 2)
View: 36853
Assigned To: docs@python Nosy List: SilentGhost, docs@python, mbussonn
Priority: normal Keywords:

Created on 2019-05-26 17:30 by mbussonn, last changed 2019-05-26 17:50 by SilentGhost. This issue is now closed.

Messages (3)
msg343569 - (view) Author: Matthias Bussonnier (mbussonn) * Date: 2019-05-26 17:30
On a local branch  with some modified docs
```
Traceback (most recent call last):
  File "/Users/bussonniermatthias/dev/cpython/Doc/venv/lib/python3.8/site-packages/sphinx/cmd/build.py", line 284, in build_main
    app.build(args.force_all, filenames)
  File "/Users/bussonniermatthias/dev/cpython/Doc/venv/lib/python3.8/site-packages/sphinx/application.py", line 337, in build
    self.builder.build_update()
  File "/Users/bussonniermatthias/dev/cpython/Doc/venv/lib/python3.8/site-packages/sphinx/builders/__init__.py", line 324, in build_update
    self.build(to_build,
  File "/Users/bussonniermatthias/dev/cpython/Doc/venv/lib/python3.8/site-packages/sphinx/builders/__init__.py", line 392, in build
    self.finish()
  File "/Users/bussonniermatthias/dev/cpython/Doc/tools/extensions/suspicious.py", line 118, in finish
    self.warn('Found %s/%s unused rules:' %
AttributeError: 'CheckSuspiciousMarkupBuilder' object has no attribute 'warn'
```

My guess is that it should be self.logger.warn, and not self.warn.
msg343571 - (view) Author: SilentGhost (SilentGhost) * (Python triager) Date: 2019-05-26 17:34
This looks like a duplicate of #36853. Do you happen to have sphinx 2 installed?
msg343572 - (view) Author: Matthias Bussonnier (mbussonn) * Date: 2019-05-26 17:37
Oh yeah, I do... and you are right this is duplicate.
History
Date User Action Args
2019-05-26 17:50:11SilentGhostsetsuperseder: inconsistencies in docs builds (Sphinx 2)
2019-05-26 17:37:55mbussonnsetstatus: open -> closed
resolution: duplicate
stage: resolved
2019-05-26 17:37:49mbussonnsetmessages: + msg343572
2019-05-26 17:34:49SilentGhostsetnosy: + docs@python, SilentGhost
messages: + msg343571

assignee: docs@python
components: + Documentation
2019-05-26 17:30:05mbussonncreate