classification
Title: test_thread fails because symbol is (no longer) exported
Type: Stage: resolved
Components: Build, Tests Versions: Python 3.8
process
Status: closed Resolution: duplicate
Dependencies: Superseder: threading._shutdown() race condition: test_threading test_threads_join_2() fails randomly
View: 36402
Assigned To: Nosy List: Michael.Felt, vstinner
Priority: normal Keywords:

Created on 2019-05-21 11:35 by Michael.Felt, last changed 2020-03-27 00:26 by vstinner. This issue is now closed.

Messages (2)
msg343016 - (view) Author: Michael Felt (Michael.Felt) * Date: 2019-05-21 11:35
On AIX, with commit 4fb15021890d327023aefd95f5a84ac33b037d19 (HEAD -> master, origin/master, origin/HEAD)

test_thread is failing.

The three sub_tests that exit as ERROR are:
ERROR: test_threads_join_2 (test.test_threading.SubinterpThreadingTests)
ERROR: test_frame_tstate_tracing (test.test_threading.ThreadTests)

These two have in common:
Traceback (most recent call last):
...
ImportError:    0509-130 Symbol resolution failed for /home/buildbot/python-master/build/lib.aix-7.1-3.8-pydebug/_testcapi.so because:
        0509-136   Symbol _PyMem_GetAllocatorsName (number 191) is not exported from
                   dependent module python.
        0509-192 Examine .loader section symbols with the
                 'dump -Tv' command.

FAIL: test_daemon_threads_fatal_error (test.test_threading.SubinterpThreadingTests)

I am guessing that:

======================================================================
FAIL: test_daemon_threads_fatal_error (test.test_threading.SubinterpThreadingTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/buildbot/python-master/Lib/test/test_threading.py", line 942, in test_daemon_threads_fatal_error
    self.assertIn("Fatal Python error: Py_EndInterpreter: "
AssertionError: 'Fatal Python error: Py_EndInterpreter: not the last thread' not found in 'Traceback (most recent call last):\n  File "<string>", line 2, in <module>\nImportError: \t0509-130 Symbol resolution failed for /home/buildbot/python-master/build/lib.aix-7.1-3.8-pydebug/_testcapi.so because:\n\t0509-136   Symbol _PyMem_GetAllocatorsName (number 191) is not exported from\n\t\t   dependent module python.\n\t0509-192 Examine .loader section symbols with the\n\t\t \'dump -Tv\' command.'

----------------------------------------------------------------------
is caused by the earlier failures.
msg365123 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2020-03-27 00:26
> Fatal Python error: Py_EndInterpreter: not the last thread

That's the bug bpo-36402 which I fixed with commit 468e5fec8a2f534f1685d59da3ca4fad425c38dd in master.
History
Date User Action Args
2020-03-27 00:26:31vstinnersetstatus: open -> closed

superseder: threading._shutdown() race condition: test_threading test_threads_join_2() fails randomly

nosy: + vstinner
messages: + msg365123
resolution: duplicate
stage: resolved
2019-05-21 11:35:53Michael.Feltcreate