classification
Title: python3.7.3 can't work after MacOS upgrade from v10.14.4 to v10.14.5
Type: Stage: resolved
Components: macOS Versions: Python 3.7
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: ned.deily, ronaldoussoren, wuwentao
Priority: normal Keywords:

Created on 2019-05-15 12:42 by wuwentao, last changed 2019-05-16 04:02 by wuwentao. This issue is now closed.

Messages (4)
msg342570 - (view) Author: wuwentao (wuwentao) Date: 2019-05-15 12:42
Hi

My python3.7.3 works well in MacOS v10.14.4 yesterday, today I have upgrade my MacOS to v10.14.5, after upgrade,I just found python3 and pip3 can't works, all the command will be run as a background program, but not foreground program.
but MacOS builtin python 2.7 works well.
so I have reported it to Apply Support for this upgrade bug.
in addition, I think I also should report it to python bug tracker.



for example:

wtwu@wtwu-mbp:~$ ps aux |grep python
wtwu             27839   0.0  0.0  4277296    844 s003  S+    8:41PM   0:00.00 grep python
wtwu@wtwu-mbp:~$ python
Python 2.7.10 (default, Feb 22 2019, 21:55:15)
[GCC 4.2.1 Compatible Apple LLVM 10.0.1 (clang-1001.0.37.14)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> print "hello world"
hello world
>>> exit()
wtwu@wtwu-mbp:~$ python3

[1]+  Stopped                 python3
wtwu@wtwu-mbp:~$ Python 3.7.3 (default, Mar 27 2019, 09:23:15)
[Clang 10.0.1 (clang-1001.0.46.3)] on darwin
Type "help", "copyright", "credits" or "license" for more information.


[1]+  Stopped                 python3
wtwu@wtwu-mbp:~$ ps aux |grep python
wtwu             27851   0.0  0.0  4268080    820 s003  S+    8:41PM   0:00.00 grep python
wtwu             27847   0.0  0.1  4263232   8576 s003  T     8:41PM   0:00.04 /usr/local/Cellar/python/3.7.3/Frameworks/Python.framework/Versions/3.7/Resources/Python.app/Contents/MacOS/Python
wtwu@wtwu-mbp:~$ python3

[2]+  Stopped                 python3
wtwu@wtwu-mbp:~$ Python 3.7.3 (default, Mar 27 2019, 09:23:15)
[Clang 10.0.1 (clang-1001.0.46.3)] on darwin
Type "help", "copyright", "credits" or "license" for more information.


[2]+  Stopped                 python3
wtwu@wtwu-mbp:~$ ps aux |grep python
wtwu             27857   0.0  0.0  4277296    836 s003  S+    8:42PM   0:00.00 grep python
wtwu             27854   0.0  0.1  4274496   8596 s003  T     8:42PM   0:00.04 /usr/local/Cellar/python/3.7.3/Frameworks/Python.framework/Versions/3.7/Resources/Python.app/Contents/MacOS/Python
wtwu             27847   0.0  0.1  4263232   8576 s003  T     8:41PM   0:00.04 /usr/local/Cellar/python/3.7.3/Frameworks/Python.framework/Versions/3.7/Resources/Python.app/Contents/MacOS/Python
wtwu@wtwu-mbp:~$
wtwu@wtwu-mbp:~$
msg342573 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2019-05-15 14:01
Thanks for the report but I am unable to reproduce the behavior you describe on another v10.14.5 system using any of the current python.org 3.7.3 macOS python binary, a built-from-source 3.7.3+, or a MacPorts 3.7.3 with either libedit or GNU readline.  First, I would check to check what the command "python3" really does.  In a new terminal window, I would expect something like:

$ type python3
python3 is /usr/local/bin/python3

Also check for any Python-related environment variables:

$ env | grep PYTHON

Since you appear to be using a Homebrew-installed python3.7, I would check the Homebrew forums and issue tracker for similar reports. You could also try reinstalling the Homebrew python3.
msg342582 - (view) Author: wuwentao (wuwentao) Date: 2019-05-15 15:56
1.my python3 is /usr/local/bin/python3, it's a link to Python3.7.3
2. I have downloaded the Mac OS install pkg file from our website, get the same result
3. my env don'T set PYTHON env , just default value
4. also tried reinstall many times with brew ,got the same result
 i think maybe some OS related issue caused it, need to confirm tomorrow
msg342623 - (view) Author: wuwentao (wuwentao) Date: 2019-05-16 04:02
Hi

we may found the root cause from the McAfee log file, as we have too many computer have the same result in our company, it may caused by McAfee AntiVirus software auto upgrade to new version and new policy , all of our McAfee AntiVirus have ATP feature enabled, after disabled ATP service, python3 works well now.

it's really a bug for McAfee, but not Python program or MacOS upgrade issue.
I'm sorry for the error bug report.

close this issue as it's not python3 program bug.

Thanks!
Wentao
History
Date User Action Args
2019-05-16 04:02:22wuwentaosetstatus: open -> closed

messages: + msg342623
stage: resolved
2019-05-15 15:56:28wuwentaosetstatus: pending -> open

messages: + msg342582
2019-05-15 14:01:21ned.deilysetstatus: open -> pending
type: crash ->
resolution: works for me
messages: + msg342573
2019-05-15 12:42:34wuwentaocreate