classification
Title: Unittest Discovery for namespace subpackages dot notation fails
Type: behavior Stage: resolved
Components: Versions: Python 3.7, Python 3.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: unittest discovery doesn't detect namespace packages when given no parameters
View: 23882
Assigned To: Nosy List: eric.smith, methane, mrwaffles, pconnell, rgammans
Priority: normal Keywords:

Created on 2019-04-25 19:04 by mrwaffles, last changed 2020-07-19 04:37 by methane. This issue is now closed.

Messages (2)
msg340857 - (view) Author: Jonny Fuller (mrwaffles) Date: 2019-04-25 19:04
Hi friends,

I noticed strange behavior involving unittest discovery with namespace packages. Using dot notation to discover test packages within a namespace package will fail, but will succeed when using path notation.

It feels awkward that dot path would fail but normal path would succeed. Is this the desired behavior?

I created a demo repo and fully documented this odd behavior here

https://github.com/JonnyWaffles/djangonamespacetestfail.
msg349971 - (view) Author: Roger Gammans (rgammans) Date: 2019-08-19 21:40
I think this is a duplicate of one (or both) of 35617, or 23882 .

Both of those have unmerged proposed fixes.
History
Date User Action Args
2020-07-19 04:37:03methanesetstatus: open -> closed
superseder: unittest discovery doesn't detect namespace packages when given no parameters
resolution: duplicate
stage: resolved
2020-07-19 04:05:09xtreaksetnosy: + methane
2019-10-28 20:48:40pconnellsetnosy: + pconnell
2019-08-19 21:40:35rgammanssetnosy: + rgammans
messages: + msg349971
2019-04-25 19:12:36eric.smithsetnosy: + eric.smith
2019-04-25 19:04:03mrwafflescreate