classification
Title: codecov.io code coverage has not updated since 2019-04-13
Type: Stage: resolved
Components: Build Versions: Python 3.8
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: gphemsley, methane, zach.ware
Priority: normal Keywords: patch

Created on 2019-04-20 23:55 by gphemsley, last changed 2019-05-12 03:35 by methane. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 13105 closed methane, 2019-05-06 06:17
PR 13146 merged gphemsley, 2019-05-07 00:18
Messages (9)
msg340588 - (view) Author: Gordon P. Hemsley (gphemsley) * Date: 2019-04-20 23:55
The last commit available on codecov.io is from a week ago (d28aaa7df8bcd46f4135d240d041b0b171b664cc):
https://codecov.io/gh/python/cpython

And the widget on the README is showing a status of "unknown".
msg340611 - (view) Author: Gordon P. Hemsley (gphemsley) * Date: 2019-04-21 15:53
In fact, it seems the last commit on master was 962b028b0c20abcf39594f08b1e5f8c36c4e5f6f 3 months ago, which doesn't even have valid report.

The previous commit, 9932a22897ef9905161dac7476e6976370e13515, was the last to have a functioning report.
msg340612 - (view) Author: Gordon P. Hemsley (gphemsley) * Date: 2019-04-21 15:58
It looks like this may be the result of the code coverage being provided by the optional gcc build, which has been failing for quite a while.
msg340613 - (view) Author: Gordon P. Hemsley (gphemsley) * Date: 2019-04-21 16:09
I'm not sure when the gcc build started failing, but it looks like the commits at the boundary failed due to max build time. Something is apparently too slow to run.
msg341415 - (view) Author: Gordon P. Hemsley (gphemsley) * Date: 2019-05-05 01:36
Testing has shown that the gcc build itself runs fine. The problem appears to be with how the coverage tests are run.
msg341448 - (view) Author: Gordon P. Hemsley (gphemsley) * Date: 2019-05-05 13:58
It seems the primary cause of the problem is simply that testing crossed the boundary of maximum execution time allotted by Travis CI.

I'm experimenting now with ways to speed up testing without losing granularity. However, given how long code coverage has been missing, it might be worthwhile to move forward on a stopgap solution that at least gets code coverage being tracked again, if not comprehensively.
msg341485 - (view) Author: Inada Naoki (methane) * (Python committer) Date: 2019-05-06 05:53
FYI, https://github.com/python/cpython/pull/7773#issuecomment-398262396
msg341666 - (view) Author: Gordon P. Hemsley (gphemsley) * Date: 2019-05-07 00:10
Hah, that's indeed where I've landed in my experimentation.
msg342237 - (view) Author: Inada Naoki (methane) * (Python committer) Date: 2019-05-12 03:33
New changeset 87068ed00927bdeaa2ae556e4241c16cf8a845eb by Inada Naoki (Gordon P. Hemsley) in branch 'master':
bpo-36684: Split out gcc and test coverage builds (GH-13146)
https://github.com/python/cpython/commit/87068ed00927bdeaa2ae556e4241c16cf8a845eb
History
Date User Action Args
2019-05-12 03:35:04methanesetstatus: open -> closed
resolution: fixed
stage: patch review -> resolved
2019-05-12 03:33:37methanesetmessages: + msg342237
2019-05-07 00:18:38gphemsleysetpull_requests: + pull_request13059
2019-05-07 00:10:56gphemsleysetmessages: + msg341666
2019-05-06 06:17:33methanesetkeywords: + patch
stage: patch review
pull_requests: + pull_request13018
2019-05-06 05:53:11methanesetnosy: + methane
messages: + msg341485
2019-05-05 13:58:21gphemsleysetmessages: + msg341448
2019-05-05 01:36:05gphemsleysetmessages: + msg341415
2019-04-21 16:09:53gphemsleysetmessages: + msg340613
2019-04-21 16:03:27SilentGhostsetnosy: + zach.ware

components: + Build
versions: + Python 3.8
2019-04-21 15:58:25gphemsleysetmessages: + msg340612
2019-04-21 15:53:48gphemsleysetmessages: + msg340611
2019-04-20 23:55:19gphemsleycreate