classification
Title: Non-embedded zip distribution
Type: enhancement Stage: resolved
Components: Installation Versions: Python 3.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Please provide a .zip Windows release of Python that is not crippled/for embedding only
View: 36010
Assigned To: Nosy List: ronaldoussoren, steve.dower, wheelerlaw
Priority: normal Keywords:

Created on 2019-04-17 20:47 by wheelerlaw, last changed 2019-04-18 13:36 by steve.dower. This issue is now closed.

Messages (3)
msg340445 - (view) Author: (wheelerlaw) Date: 2019-04-17 20:47
Pretty straight forward request. It would be nice if there was an installation method where I can just unzip a Python distribution rather than running an installer. 

Specifically this is for getting Python to run in Wine. Right now, Python for Windows runs fine under Wine, but the installer doesn't, so a manual process of running the installer on a Windows machine and then copying the installed resources to a Linux machine with Wine installed. A zip distribution would solve this, since I could just unzip it and run it under Wine.
msg340482 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2019-04-18 11:24
This is a duplicate of issue36010, which contains an explanation of why there is no installation method with a zipfile.
msg340487 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2019-04-18 13:36
Also see the packages on nuget.org, which are essentially just zip files (with metadata and installation tools available).
History
Date User Action Args
2019-04-18 13:36:29steve.dowersetstatus: open -> closed
superseder: Please provide a .zip Windows release of Python that is not crippled/for embedding only
messages: + msg340487

resolution: duplicate
stage: resolved
2019-04-18 11:24:55ronaldoussorensetnosy: + ronaldoussoren
messages: + msg340482
2019-04-18 06:10:58xtreaksetnosy: + steve.dower
2019-04-17 20:47:47wheelerlawcreate