classification
Title: unittest.TestCase: "subTest" cannot be used together with "debug"
Type: behavior Stage: resolved
Components: Library (Lib) Versions: Python 3.9
process
Status: closed Resolution: duplicate
Dependencies: Superseder: unittest subTests() fails when called from debug()
View: 34900
Assigned To: Nosy List: dmaurer, xtreak
Priority: normal Keywords:

Created on 2019-04-08 10:24 by dmaurer, last changed 2019-04-08 16:39 by xtreak. This issue is now closed.

Files
File name Uploaded Description Edit
utest.py dmaurer, 2019-04-08 16:28 Script reproducing the problem
utest.py dmaurer, 2019-04-08 16:35 Script reproducing the problem
Messages (4)
msg339607 - (view) Author: Dieter Maurer (dmaurer) Date: 2019-04-08 10:24
"subTest" accesses "self._outcome" which is "None" when the test is performed via "debug".
msg339608 - (view) Author: Karthikeyan Singaravelan (xtreak) * (Python committer) Date: 2019-04-08 10:31
Can you please provide an example script to reproduce this? There is similar None check fixed with issue34900
msg339658 - (view) Author: Dieter Maurer (dmaurer) Date: 2019-04-08 16:35
This is a duplicate of issue34900
msg339659 - (view) Author: Karthikeyan Singaravelan (xtreak) * (Python committer) Date: 2019-04-08 16:39
Thanks, just confirmed the commit fix with the given file.
History
Date User Action Args
2019-04-08 16:39:55xtreaksetsuperseder: unittest subTests() fails when called from debug()
resolution: duplicate
2019-04-08 16:39:34xtreaksetmessages: + msg339659
2019-04-08 16:35:32dmaurersetstatus: open -> closed
files: + utest.py
messages: + msg339658

stage: resolved
2019-04-08 16:28:26dmaurersetfiles: + utest.py
2019-04-08 10:31:30xtreaksetnosy: + xtreak
messages: + msg339608
2019-04-08 10:24:31dmaurercreate