classification
Title: is there a python implementation of the cpython commandline interpretor?
Type: Stage: resolved
Components: Argument Clinic Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: larry, wis
Priority: normal Keywords:

Created on 2019-04-05 12:40 by wis, last changed 2019-04-05 12:41 by larry. This issue is now closed.

Messages (2)
msg339499 - (view) Author: wis (wis) Date: 2019-04-05 12:40
this algorithm: https://github.com/python/cpython/blob/34ef64fe5947bd7e1b075c785fc1125c4e600cd4/Python/coreconfig.c#L1644

I need a python library that does that to fix this answer
https://stackoverflow.com/a/55413882/4178053
I need to get the correct path of the script from the commandline of the python process.

I searched for libraries or implementations and couldn't find one, can someone help me? I can't read C.
msg339500 - (view) Author: Larry Hastings (larry) * (Python committer) Date: 2019-04-05 12:41
The Python bug tracker is not your personal resource for answering programming questions.
History
Date User Action Args
2019-04-05 12:41:50larrysetstatus: open -> closed
resolution: not a bug
messages: + msg339500

stage: resolved
2019-04-05 12:40:52wiscreate