classification
Title: Windows build failure when use the code from the GitHub master branch
Type: Stage: resolved
Components: Windows Versions: Python 3.8
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Manjusaka, paul.moore, steve.dower, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2019-04-05 11:00 by Manjusaka, last changed 2019-04-06 04:28 by Manjusaka. This issue is now closed.

Messages (3)
msg339494 - (view) Author: Manjusaka (Manjusaka) * Date: 2019-04-05 11:00
I use Visual Studio 2017 to build the source code from the master branch. But it failed. The output message shows that I lose my ffi.h.

I find that the developer had removed the libffi_module directory under cpython/modules/_ctypes  since 32119e10b792ad7ee4e5f951a2d89ddbaf111cc5

I guess that maybe that's the problem why I get failure
msg339512 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2019-04-05 19:06
We added a new dependency.

Run a build using PCbuild/build.bat and it will download it for you. Then building through VS should work again.
msg339524 - (view) Author: Manjusaka (Manjusaka) * Date: 2019-04-06 04:27
Done,thx
History
Date User Action Args
2019-04-06 04:28:28Manjusakasetstatus: open -> closed
resolution: not a bug
stage: resolved
2019-04-06 04:27:51Manjusakasetmessages: + msg339524
2019-04-05 19:06:37steve.dowersetmessages: + msg339512
2019-04-05 11:00:57Manjusakacreate