classification
Title: Provide a simple way to delete and edit python's welcome message
Type: enhancement Stage: resolved
Components: Interpreter Core Versions: Python 3.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: rhettinger Nosy List: SilentGhost, benp, iritkatriel, rhettinger, steven.daprano, xtreak
Priority: normal Keywords:

Created on 2019-03-10 14:17 by benp, last changed 2020-10-01 01:52 by rhettinger. This issue is now closed.

Messages (8)
msg337614 - (view) Author: Benoit Pilatte (benp) Date: 2019-03-10 14:17
To my knowledge and extensive research on the problem, there is no simple way to disable python's welcome message:

"""
Python 3.7.2 (default, Jan 13 2019, 12:50:01)
[Clang 10.0.0 (clang-1000.11.45.5)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
"""

It is appended to stdout before the execution of `PYTHONSTARTUP` and is very difficult to remove. This could be easily fixed by:

 1. Allowing modification of the welcome message in `PYTHONSTARTUP`
 2. Provide an option to disable it (IPython provides a `--no-banner` option to disable it)
 3. At least provide a documented way of disabling it without hijacking the shell.
msg337615 - (view) Author: Karthikeyan Singaravelan (xtreak) * (Python committer) Date: 2019-03-10 14:19
Does python -q help in this case?

$ python -q
>>>
msg337616 - (view) Author: Benoit Pilatte (benp) Date: 2019-03-10 14:27
Yes, I forgot about that, but is there a way to edit it ? 
I just want to add a line after the first one to give system information.
Disabling it and re-printing it seams a bit overkill and I don't want to alias `python` to `python -q`.
msg337617 - (view) Author: Steven D'Aprano (steven.daprano) * (Python committer) Date: 2019-03-10 14:42
Why do you want to disable the welcome message?

> I just want to add a line after the first one to give system information.

Sounds like you just want to print something extra, after the welcome message has been printed.
msg337618 - (view) Author: SilentGhost (SilentGhost) * (Python triager) Date: 2019-03-10 14:49
You could define PYTHONSTARTUP variable and modify everything to your heart's content. https://docs.python.org/3/using/cmdline.html#envvar-PYTHONSTARTUP
msg377544 - (view) Author: Irit Katriel (iritkatriel) * (Python triager) Date: 2020-09-26 21:13
I think this issue can be closed, there is nothing to do on it.
msg377549 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2020-09-26 23:58
> I think this issue can be closed, there is nothing to do on it.

Right.
msg377723 - (view) Author: Irit Katriel (iritkatriel) * (Python triager) Date: 2020-09-30 21:28
Raymond, I think you intended to close this but missed a click.
History
Date User Action Args
2020-10-01 01:52:53rhettingersetstatus: open -> closed
stage: resolved
2020-09-30 21:28:13iritkatrielsetmessages: + msg377723
2020-09-26 23:58:09rhettingersetnosy: + rhettinger
messages: + msg377549

assignee: rhettinger
resolution: not a bug
2020-09-26 21:13:17iritkatrielsetnosy: + iritkatriel
messages: + msg377544
2019-03-10 14:49:13SilentGhostsetnosy: + SilentGhost
messages: + msg337618
2019-03-10 14:42:03steven.dapranosetnosy: + steven.daprano
messages: + msg337617
2019-03-10 14:27:45benpsetmessages: + msg337616
2019-03-10 14:22:25benpsettitle: Provide a simple way to delete python's welcome message -> Provide a simple way to delete and edit python's welcome message
2019-03-10 14:19:10xtreaksetnosy: + xtreak
messages: + msg337615
2019-03-10 14:17:29benpcreate