classification
Title: Slight documentation quirk for random.random
Type: behavior Stage:
Components: Documentation Versions: Python 2.4, Python 2.3, Python 2.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: georg.brandl Nosy List: amaury.forgeotdarc, amc1, georg.brandl
Priority: normal Keywords:

Created on 2008-08-20 22:42 by amc1, last changed 2008-08-20 22:49 by amaury.forgeotdarc. This issue is now closed.

Messages (2)
msg71582 - (view) Author: Allan Crooks (amc1) Date: 2008-08-20 22:42
The documentation for random.random function shows this:
  random() -> x in the interval [0, 1).

That should either be "[0, 1]" or "(0, 1)".
msg71584 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2008-08-20 22:49
[0, 1) denotes an interval, not a python object; 0 is included, 1 is
excluded.

And it follows (one of) the standard syntax to express intervals:
http://en.wikipedia.org/wiki/Interval_notation
History
Date User Action Args
2008-08-20 22:49:31amaury.forgeotdarcsetstatus: open -> closed
resolution: not a bug
messages: + msg71584
nosy: + amaury.forgeotdarc
2008-08-20 22:42:03amc1create